Can't publish to Orchestrator Tenant Processes Feed

The “Orchestrator Tenant Processes Feed” option is not available in the dropdown for me. I only get the “Orchestrator Personal Workspace Feed” option to choose. From the research I have done, I believe it is related to my role/permissions but I don’t know how to adjust them. Can you please help me. I have the community version. Thank you.

Hi @scott.doscher

Publish the package as custom package and upload it into the orchestrator

It Helps!

HI,

Can you try to add Allow to be automation publisher role to your account?

Regards,

Hi,

There might be missing permission.
please check below link

Why orchestrator feed and tenet feed not available to publish - Help / Studio - UiPath Community Forum

TY @Yoichi. I did that. Now I am getting “No runtimes available” when I am trying to manually run the automation. What does that mean?

That means you haven’t assigned any licenses.

You have to put robot(s) into the folder, machine(s) into the folder, and assign runtimes to the machine(s).

TY @postwick In the process of putting the machine into the folder, I got this msg:

Information message
Runtimes can be assigned to this machine after their license is activated.

I don’t think I have licenses. Could that be because I am using the community version? Where would I find the licenses if I did have them?

This is the step I can’t get past:

  1. In the Publish options tab, for the Publish to option, select Orchestrator Tenant Processes Feed, the location where unattended robots can access the automation.

I don’t have “Orchestrator Tenant Processes Feed”, as an option in that dropdown. I only have “personal workspace” option.

In Orchestrator give your user the Automation Developer role.

If you have an Automation Express license, you can use only the Personal Workspace.

In order to see if you are using the Automation Express license, you can open your Studio → Home → look in the left bottom information

If you are trying to publish library, make sure that in Orchestrator → Tenant → Settings → Deployment → Libraries → you select the option to include also the Tenant location

Ty @marian.platonov It does show that I am using Automation Express license. I did change the settings like you describe but still don’t have the tenant option. Ugh. I just need the automation to run on a schedule. Am I approaching this wrong? Where should I go from here? TY again.

First of all, if you want to publish directly from Studio to Orchestrator, you will need a Studio license (Automation Developer), and you will remove from your user the Automation Express license allocation. Then, you will need an Allow to be Automation Publisher role in Orchestrator.

Now, I think you can only publish to Personal Workspace, or to a Custom location. If you are publishing to a custom location, you can easily upload the process manually from Orchestrator ->Tenant → Packages.

TY @marian.platonov I will experiment with your feedback and report back. Thank you again.

@marian.platonov


I now have the package in Orchestrator, but I can’t schedule it. I have tried so many things now, I don’t know where to go next. Now that I have the package in Orchestrator, would you help me with the steps to schedule the run of it, say at 10:00 AM EST each day?

First of all you will need an unattended runtime for that in Orchestrator.
The robot to be installed in Service Mode.
In Assistant to be connected using the Client ID and Client secret from a Machine Template.

References:

https://docs.uipath.com/robot/standalone/2023.4/user-guide/attended-vs-unattended-robots

After publishing the package, you have to go to the folder, to Processes, and create a Process from the package.