Can't enter data into field if the existing content is not the same every time


#1

Hello, ive tried numerous searches but maybe i’m using the wrong search terms.

When i try to put a value into a field in a Windows Application i can only seem to do that if the existing value is the same every time.

for example if i go to a subscription start date field and i want to change the entry from 1/1/2018 to 1/9/2018 i can only do that if the pre-populated entry is the same each time. That is not always the case.

the same applies to drop down menus - i can only get uipath to click if the existing value matches what was there when i clicked INDICATE ON SCREEN.

is there a way to ignore what is there and forge ahead with mouse clicks / key strokes?
i tried F3 to indicate an area on screen without success.

Thanks in advance.
SM


#2

What are the selectors you’re using?
Explore with UiExplorer (check Academy if you’re not sure how to use it).

From what you wrote it seems generated selectors contain field content, you’ll need to adjust them to be dynamic or use different properties.


#3

Thanks Andrzej,
i wish i could attach a screen capture to show you exactly what i meant.
I am using software called Aptify that interacts with our customer database.
many fields are blank (work great) but many fields are pre-populated… those give me problems.
.
i will explore the explorer. thanks for the tip.
SM


#4

I found my answer. It was in the Selector >
since my field can have different values i needed to set this to a wildcard value as per this instruction >

when i click my field… it lifted the value in that field as part of the selector.
when i run the process again the same field has a different value and my process pauses.
.
if i got to my selector and replace the filed value with *
and use the “attach to live element” option
it works just fine.