Cant click on a button in a browser

Iv’e tried to click on a button several times with different identifiers with no luck.
What are my other options except:

There is very little information given from the Html. No name or id.

A little more info would help, if you could share your workflow and website if possible.


Hi, its an internal system so i cant give out to much infromation:

This is the button im trying to press. Yet when i run the workflow it clicks the First part of the text “Gim…”
Ive tried all these identifiers.

and fuzzy etc. All of them do not seem to be working.
thanks you/N

you could use click image opposed to click, as this will not rely on more specific selectors

or could you try using the tab hotkey until the button is highlighted then send an enter key to click it

Hello, so you want to click the Sign In → Button? You select that with a click activity? What do the elements look like? What do you use as anchor? Your results is it is clicking the GIM UI… text?



Welcome to the community

Can you show the proper selector…

I see a button on left but your selector shows only a span…and youa re using fuzzy and image…instead use strict selector open ui explorer and find a proper selector…Mostly the selector looks like this

<webctrl tag='BUTTON' type='Submit' />


<webctrl tag='SPAN' innertext='*Sign In*' />

Hope this helps


Hi i wish it was that easy,
It’s written in EmberJs - so theres not much to go on, its not even identified as a button.
I just just the “”

and this is the result, it clicks the marked area “Gim…”
and this is also validated as green
And this is only using 1 strickt selector.

Can you try using click image?

ive tried that, does not work either im afraid :confused:

when the robot has clicked on GIM can you try using tab to see if it then moves down to the button, and then enter to see if it activates it

That made it procced to the next step yes

maybe you could code that with using send type into for the tab and then type into for enter


then try getting href and navigate using navigate browser…base url needs to be appended I guess

Else as suggested by @aquinn you can go with key strokes

Alternately try using Active Accessibility mode or cv clicks as well might do the job