Submit button on form will not send command


I have a process that pastes a text block into a form and then I press the submit button. My issue is the id field of the button changes every time the form is loaded. For example, when I edit the selector of the button, I see this:

<webctrl id='ember74' tag='BUTTON' />

The next time I load the form, the selector on the button may read:

<webctrl id='ember325' tag='BUTTON' />

I have tried putting in a wildcard for the number so no matter what it is, it will pass:

<webctrl id='ember*' tag='BUTTON' />

Have also tried the whole id as a wildcard:

<webctrl id='*' tag='BUTTON' />

Neither wildcards will work. For the life of me, I just cant get it to work. I am able to get all the way through my process but just can’t Submit.

After pasting my text block, I have tried sending hot keys (tab, tab, enter) to get to the submit button but even that will not select the button correctly.

When I manually paste my text block in and click submit I have no issues so I’m not understanding why my process is not working.

Any help would be greatly appreciated,



if you spy the button and test a click with the full id (eg. ) does it work?
Because otherwise it’s a problem of the click type, and I’ll suggest using another click method, like Send Hardware Message.

Moreover, if you cannot spy the button you can try to extract the page text and click on the “Submit” text.

Let me know if any of this works.



Thanks for the reply. Below is a pic of the full button when I do an Inspect. The highlighted line is what I am seeing in the Selector field within Studio.

I am sure the answer may be here I’m just not seeing it.

Here is what I see in UI Explorer:

And this:


Hi @djkmod83,

Have you tried using the id attribute as id='ember*' and adding the aaname and type attributes? I imagine this would work if there is only one Submit button available

Finally got around to trying this and i opened the element in UI Explorer, selected the id, aaname and type attributes then changed the id to ember* and still does not work unfortunately. But yes, this is a pop up window that only has 1 Submit button


uncheck the id and just keep only aaname.

this will works for you