Can't Automate Putty 0.67

Hi Guys,

I am trying to automate Putty 0.67. But even when I run UiPath Studio as an administator it won’t find it. I can only add informative Screenshots. But it does neither find it as a selector nor as an image. Neither the click text/image work.

Any ideas what to do?

Thanks alot!

I’d use start process activity to open putty.

Ok I might need to specifiy my problem.
I already have it opened by using start process. The problem is I cant interact with it in any way.

Ok so you cant interact in design time. Is UIExplorer working?
my 2019.11 version is working fine with putty


Try using attach window and use key strokes wherever possible.

Hey Guys,

I cant use attach window either. It does not recognize Putty when I indicate it on screen.

UIExplorer is working, yes. I’m Using 2019.4.4. But even there I can’t select putty.

Does activities like type into or get text working in runtime if you copy selector from UiExplorer?

You can also try to copy whole project on side, delete project.json, open any xaml from project and let studio recreate project.json. Than try how it works in design time.

I dont get any selector from UIExplorer. I cant indicate it. It doesnt recognize its even there. Are there any exisiting Selectors I can use?

If UIExplorer cannot get selector than I think providing correct one would still fail during runtime.
However Ill post here mine selectors from putty 0.7:
main window:<wnd app='putty.exe' cls='PuTTYConfigBox' title='PuTTY Configuration' />

Host name input: <wnd app='putty.exe' cls='PuTTYConfigBox' title='PuTTY Configuration' /> <wnd cls='Edit' idx='1' />

If it is possible Id try to upgrade, downgrade(or at least reinstall) studio on that machine.
Looks like some incopatibility between uipath tools and system on that machine.

Thanks! I will update UiPath and see if it helps!