Can't automate my Gmail and facing error

Hi,

I am trying to automate my gmail with perfect credentials. But my bot always throw an error.

For error reference please check this screenshot.

Thanks in advance :slight_smile:

1 Like

No worries
Kindly check once with the gmail and password variable has the correct mail I’d and password
I hope that’s the issue as error message implies the same
Cheers @Irfan

I have cross checked all bro. But still getting same error :frowning:

Hi,
Its seems problem with username and password. Check your credentials and rerun the bot :grinning:

@Vish2148 i have tried my credentials on gmail and it’s working. When I am trying to access through Our tool it’s not working :frowning:

Did you changed your security option on your gmail account ??

@Vish2148 Yeah I have changed bro

i can check your main.xaml because if you havent given @gmail.com from uipath studio it will give exception of the same

Hi @Irfan

You got to enable smtp in gmail settings for your credentials to work. By default it is disables in gmail settings. You can do a simple google search on how to get it enabled as required. And I believe you have to use get SMTP mail if I remember correct…

Can I have a view on your Email variable and it’s value defined in the variable panel with a screenshot if possible, as it looks very clear that either the credentials or password is not passed correctly
—and to make sure that gmail settings also allows and ensures the uipath iteraction with gmail
We can go for

  1. On your computer, open Gmail.
  2. In the top right, click Settings Settings.
  3. Click Settings .
  4. Click the Forwarding and POP/IMAP tab.
  5. In the “IMAP access” section, select Enable IMAP .
  6. Click Save Changes .

@Irfan
Brother… Please follow the below steps and it should work…

  1. Open Gmail Account Settings
  2. Go to Security Tab
  3. Turn on " Less secure app access"

Note : Please note this setting makes your Google account vulnerable. So please proceed with caution.

Cheers!! :slight_smile:
Happy Automation!!

1 Like

@Palaniyappan Bro here is my gmail screenshot. I have enabled POP And IMAP

@Palaniyappan Bro here is my variables screenshot and i am replaced my mail id and password with “*” for security purpose

Thanks to all @Palaniyappan @Arun_Prasad1 @Lahiru.Fernando @Vish2148. Now it’s working. Now I am able to automate my gamil.

Cheers :slight_smile:
Happy Automation Guys :slight_smile:

1 Like

@Irfan Brother. Please let us know which solution fixed the issue and please mark it as the solution. :slight_smile:

@Arun_Prasad1 Your solution fixed my problem. I have marked as solution also.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.