Cannot use Start Process or Open Application to open files in personal one drive

I can’t get start process or open application to open a pdf file on onedrive. It works fine when the file isn’t located on onedrive. On Adobe I get "There was an error opening this document. File cannot be found error.

My Filename is “C:\Program Files (x86)\Adobe\Acrobat Reader DC\Reader\AcroRd32.exe”

And for arguements I’ve tried
"/A " + " " + pdfLocation + " "
"/A " + “” + pdfLocation + “”
"/A " + pdfLocation
“” + pdfLocation + “”
" " + pdfLocation + " "
pdfLocation

Hi @Keithm,
Welcome to the Community!
First things first. Try manually open AcroRD32.exe and check if it’s opening reader. I had cases where this executable file was not opening properly. If it’s working manually then try this:

File name: "C:\Program Files (x86)\Adobe\Acrobat DC\Acrobat\AcroRd32.exe"
Argument: "/n <path to pdf>" (like "/n C:\Users\test\Desktop\blabla.pdf")

Opening the file works fine on my documents folder using the argument you’ve said but opening onedrive files doesn’t work using “/n OnedriveFilePath”. I also noticed if I open a file in pdf reader using the file location bar it doesn’t work but if I browse to the file it does work.

I’m just guessing but it can be related to this:
https://support.microsoft.com/en-us/help/4026385/windows-see-your-onedrive-files-in-file-explorer

Tried that out and no change. I seems to be related only to .pdf files on onedrive as I can open excels on onedrive through start process and .pdfs on my desktop or documents.

To check if this problem is not related just to UiPath, please try to open same pdf with use of these arguments using command line or Run option. If there will be same problem to open pdf file then I thing it’s a problem strictly related to PDF<->One Drive. Then maybe contacting with Adobe is worth considering.