Cannot set unknown member - UiPath.Core.Activities.InvokeWorkflowFile.ArgumentsVariable

Hi,

I seem to be encountering this issue when trying to run a process from Orchestrator and can’t figure out why. I’ve looked at other posts with similar issues and tried to apply the fixes from there but with no success.

The process is working successfully if I run it from Studio, it only fails when executed from UiAssistant or Orchestrator. I’ve resolved all dependencies within the project, tried republishing and a lot more.

Has anyone else encountered this issue and know a resolution?

Thanks,
Paul

This is probably too basic and dumb to be the cause, but still checking to make sure…

Are there any Invoke Workflow calls in the process where a workflow was modified such that an argument was added or removed, but maybe one of the Invoke Workflow calls to that workflow weren’t updated?

Try this if you haven’t already done this.
Go to the Project view and repeat for each workflow:

  1. Right-click the workflow
  2. Click Find References
  3. Based on the results, go to each workflow call and Import Arguments to make sure the arguments list is up-to-date.
    This is usually easy to detect since the misaligned workflow calls will show the number of arguments highlighted in orange colour.

Once again, sorry if this is too basic a suggestion. Sometimes, it’s the little things that get us, so trying to cover all the bases.

Thank you for the suggestion.
Nothing is too basic as you said it’s always the little things.

Unfortunately, it wasn’t the case for this. I went through all of the Invokes and that hasn’t solved the issue. Everything is aligned and I am able to run the process correctly from Studio as well.

Hi @Paul_Kis ,

I believe you have already used logs in your process.
Are you able find the exact place where the bot is failing?
Just implement logs on start and end of Invoke workflow to find the exact failure place, once you find out the failure point then just remove the invoke workflow and place new invoke workflow and pass all arguments again.

Sorry, I forgot to mention this. The job completely faults so no logs are produced.

As soon as you start the process from UiAssistant or from Orchestrator, 1 second later the Job faults with the above error message.

Try steps mentioned in below link.
Also try to clean your temp files and .nuget files.

Also clean your temporary packages

USERPROFILE%.nuget
%LOCALAPPDATA%\UiPath.cache
%LOCALAPPDATA%\NuGet
%LOCALAPPDATA%\Temp\NuGetScratch
%LOCALAPPDATA%\Temp\nuget