Cannot open application. DLL compatibility issue?

I’m trying to open a specific application but could not proceed because of the error below. How to proceed with this kind of problem?


Hi @ace.alcid,
Welcome to the Community!
If it’s application other than UiPath’s then I’m afraid we can’t help you as we don’t know what happened and why some other applications may refuse such error. You should check this in places dedicated for such application.

Hi @Pablito. Thanks for the response. I’m trying to automate something using UIPath Project Studio and I’m having this kind of error when trying to open a specific application from my PC. I already tried using both Open Application and Start Process activity. Both results to the same error.

Can you please show me the details you have when indicating application using Open Application activity?
I mean what you have in properties:

1 Like

See details below:


From what I see SPI Controller application runs with use of quite old Net Framework 3.5. I’m not 100% sure but please check if you have both 3.5 version as well as 4.8 (the newest) required by Studio. Maybe there is some compatibility issue between.

Yes, you are not wrong with that. The SPI Controller uses Microsoft .NET Framework 3.5. Is there any work around we could do about this?

As I said, I’m not 100% sure if this is the reason of an issue. But you can have both frameworks installed.