Cannot convert Excel Value to System.Int32


I am doing a project for my university project which reads the excel file and uses vlookup and gets the result out but i am facing a problem in running it.

At first i was doing on studioX but some solutions were to change the variable to int32, so i changed from studioX to studio and changed the variables but still not working.

Could somebody help me out?

Hello @m.jazib

Welcome to UiPath Community.

Did you try converting the Int value to the respective Datatype (say String)

If still facing issue, would you be able to share your workflow ?


Hey @m.jazib

Can you try the below steps,

  1. Clear the existing variable “ADD”
  2. Create a variable in the Output Field. (ctrl + K). So the variable will be created of the same type by default.


@jeshwanthaloy here is the workflow section where i am facing the issue :-

so, basically what i want to do is get the ID from user and check the excel sheet for the ID and print its address.

@GouthamVijay I did try the steps you suggested but still gives out the same error

Thanks @m.jazib

Can you retry by changing both ADD and AUD to String ?


tried already, still same

Can you try the below ?

  1. Get a “Cell Value” as input from the user. Example : A1
  2. Pass the same to Value to lookup
  3. In range click Excel → Indicate in Excel and indicate the whole range
  4. Column Index must be the column number. Example : if you need to lookup to the column A, then then value should be 1.
  5. Save the value to OutputVariable.

This works !

Please try and mark this as solution if its all good.

Happy automation. Thanks !!

1 Like

Hi ,
The value can be opened in the Advanced Editor in which convert the value from Saved.values(Of ExcelValue) variablename to Saved.values(Of Int2) variablename

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.