Vlookup problem using studio x

hi, anyone can help me on this regarding vlookup problem. im using studio x community

Hi @Nur_Amin

Make sure the string that you are trying to search in excel is string type.

hi can elaborate more on this?


If you are looking for a string value then you have to pass the string variable in vlookup
If you are looking for a integer value then you have to pass the int variable in vlookup

It would be great if you provide the more information like about the value you are searching in the excel and what type it is.

hi book 1 is my data sample while excel file named vlookup is the value i want to lookup
Vlookup.xlsx (8.7 KB)
Book1.xlsx (8.6 KB)

Hi @Nur_Amin

Please check on this xaml

BlankProcess10.zip (77.5 KB)

Hope this helps!!


Check this:
Vlookup.xlsx (8.7 KB)
Book1.xlsx (10.4 KB)
Sequence.xaml (12.6 KB)

hi i cannot open the workbook, im using studio x UiPath community version

Hi @Nur_Amin

Try this

VlookUp.zip (227.8 KB)

hi, i cannot open this workbook. im using studio x community version

Have you tried this? @Nur_Amin

It is working


Check these:

hi, may i ask why u copy and paste ?


Copying the sheet from excel1 to excel2

but u did not add sheet?


After completing the process deleting that sheet

I tried to do the script using my real data but stuck in copy and paste as sheet 2 not exist because i did not add new sheet


It creates new sheet as Sheet2 you no need to create the sheet in that excel

no need to add insert sheet?

Yes @Nur_Amin

Copy/Paste Range activity creates the sheet and add the data into that sheet