Can "Type Into" activity be used to type integers?

I am trying to use the “Type Into” activity to pass an integer to another program. Since “Type Into” seems to only handle strings, I first converter the integer variable to a string. The program I am passing the string to will not accept the string. The other program throws an error stating that the input is not a number. Is it possible to force “Type Into” to type an integer rather than a string?

Thanks for your help.

Hi.

Programs (ie websites and applications) only accept strings as input. If it is saying it is not a number, then I would suspect that your TypeInto is trying to input the wrong value. You might check what you are typing into the program to make sure it’s correct as you would type it manually.

To answer your question, TypeIntos only work with strings, but programs only accept strings (ie text boxes). So, if there is an error, then the string must not be in the format of a number.

Hope that helps.

Regards.

Not sure of the Application you are using which doesn’t support Strings.
You can try enabling SimulateType property of Type Into Activity and test.

Hi @banderson

Can you share the error or xaml to easily adress the issue .

cheers

Happy learning

2 Likes

Unfortunately the forum setting do not allow new users to upload attachments, so I cannot share the xaml. Currently the sequence I am having trouble uses “assign” to create a string variable called order_number (I’m using assign for troubleshooting purposes - in the future this will be an in argument from another sequence), then “type into” with Order_Number+“k[enter]”. Currently the “type into” has the EmptyField setting turned on (the field defaults to a 0 that needs to be erased first) but no other setting turned on. The sequence then uses “Get Text” to extract an order status from the other program.

When I run the sequence, the other program throws an error “Number Required”. This is exactly the same error that it throws if I try to manually type a letter into the order number box.

Thanks for any help you can give.

I actually just got it figured out. If instead of following the Order_Number with “k[enter]”, I use “k[numEnter]” it works just fine. Seems to me like a ridiculous distinction to make, but it got the problem solved.

Thanks to everyone for your suggestions.

That seems to be an issue with how the application behaves. numEnter is the enter key on the numberpad, which is different from Enter on the regular keyboard. We have a few applications at our company where we need to distinguish between the two.

Glad you were able to figure it out!