Can not connect to Orchestrator from environment requiring proxy authentication

Hi,

I tried to connect UiPath Orchestrator with UiPath Robot Settings as part of UiPath Academy.
https://academy2016.uipath.com/

My company network environment needs to the proxy authentication to connect outside site.

I changed the setting files, UiRobot.exe.config and NuGet.config,
according to Proxy blocking Orchestrator .

However I cannot reach the above server and
it was shown the error dialog "リモート名を解決できませんでした。: ‘academy2016.uipath.com
(I’m sorry for Japanese error message. Perhaps I guess message by English “Remote name cannot be resolved.”)

I tried the proxy address included the username and password format but it is failed to connect server.

UiRobot.exe.config

  <system.net>  
    <defaultProxy>  
      <proxy  
        usesystemdefault="true"
		proxyaddress="http://<username>:<password>@<proxy-host>:<proxy-port>"
        bypassonlocal="true"
      />
    </defaultProxy>  
  </system.net>  

NuGet.config

<configuration>...
	<config>
	<add key="http_proxy" value="http://<username>:<password>@<proxy-host>:<proxy-port>" />
	</config>
</configuration>

How can I resolve this connection?

Regards,
Tanaka

1 Like

Hello!

Check it out this Troubleshooting. Maybe can help you with your problem.

Regards,

1 Like

Hi @jugit
Did you resolve this issue?
I have the same problem.:cold_sweat:

Hi @jugit,

I am also getting same problem. Did you resolved this issue? If yes, could you share the solution here.

Thank you in advance.

@tango @ashvinpinjarkar
Sorry for my late response.
unfortunately lm not resolved.

Why do not you ask your company’s network administrator!?
My company’s network may be blocking access from an external server.

1 Like

@jyugit
Thank you for your response.
I think this is not real network issue, because my second robot is connecting to same server.

Yes, its network issue and I am in a process to resolve it. Thank you for your quick response…

But If it is not network issue then UIPath Support team recommends to enable logging as below:

Could you please enable the detailed logs ans send the error details. Please follow the steps given below to enable the detailed logs-

Go to Windows -> Run -> Type in “Inetmgr”
Expand Sites -> Select the Orchestrator website -> Right Click on it and click on “Explore”
Now look for web.config file, and make the following changes as explained below.
Set the CustomErrors mode to = “Off”

  1. Set the httpErrors errorMode = “Detailed”

  2. Please reset the iis after performing the steps in order to ensure that changes take effect.

Hello guys!
Still no answer to this Topic?

I get the same error while connecting to Orchestrator URL:
RemoteException wrapping System.Net.WebException: The remote server returned an error: (407) Proxy Authentication Required.
at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
at System.Net.Http.HttpClientHandler.GetResponseCallback(IAsyncResult ar)

I’ve updated the proxy.config file with the organisation’s proxy address but still get the same error.
As a workaround somehow I manage to connect successfully if I first open IE an connect to a page.
Is it possible to use UserName and Password for proxy authentication?