Calculate Client Security Hash exercise - Assign error

Can anyone explain this error please in the advanced training “Calculate Client Security Hash”:

Error message: “Overload resolution failed because no accessible ‘Select’ could be obtained with these arguments”…

@ColinCrabtree

Declare dt_Wls variable as DataTable and then try it.

1 Like

As you are using data row array use the ‘For each’ loop rather than ‘for each row’ loop in there.

Thanks for the assistance. So this solved that problem but there still seems to be a bigger issue:

The assign below that was having the issue now has no issue as I changed dt_WIs to a type of DataTable:

image

The above assign is done after the following Invokes:

System1 login, System1 navigate to work items and then finally System1 Extract data.

The below image shows the arguments for the system 1 Extract data. You will see that the Type there is still DataRow. I tried change it to DataTable but it reverts back to DataRow when I go back into import arguments.

image

This is what the System1 ExtractData WF looks like, first showing the Variables then the Arguments and finally an assign.

image

I think my understanding in getting the full extracted data table from the Browser to a filtered version of only the types “WI5” and “Open” is wrong. My understanding is this:

The Data scrape loads the entire Browser table into the Variable ExtractDataTable.
The Assign loads the entire Data Table from ExtractDataTable to the Argument dt_WIs so that it can be passed back to the Init WF.
In the Init WF the Assign loads only the type “WI5” and Status “Open” items from the dt_WIs table to the WIlist Table.

Where am i going wrong ?

Well,

To further dissect this issue I suggest you share your project file. I have seen that it is either a type mismatch, or argument passing is going wrong or you are using a data row array rather than a data table which might be the reason for automatic change of type.

Hi There… I am not sure if I am doing this the correct way as I am not sure how projects are stored.

Client Security Hash Project.zip (2.0 MB)

@Raghavendraprasad is this ok ?