Bug Report: Generate Data Table From Text using tab-delimited TXT files

UiPath Team:

When I try and use the Generate Data Table Wizard within the Generate Data Table from Text activity, when I copy the TXT file contents that has tabs as delimiters, I am seeing that the example data that I pasted appears to place everything in the first column and does not separate these into their designated columns.

I am not sure if anyone has brought this up but this appears to be a bug within that activity.

you tried with other column seperator ?

Yes, there are spaces in my data (as how you would write a sentence) and that appears to work.

please share the sample data thats great for go through the things

293 Diameter Black 3256_30_22_16_5.txt (407 Bytes)

Hi @eric.brenner

Try out with column Separator → Space

If you using the Duplicate values as a header it will through an error like below


we cant try with space for seperate the column because in column names he is keeping space already


It seems limitation of the wizard. (Tab is automatically converted to space in the input text field)
So I recommend to check actual run (without wizard) like the following settings then check it using breakpoint and locals panel.


For ease for everyone, I’ll keep my comments here. Sorry for double posting.

@Yoichi That seems to have worked. Thank you. Regardless, the Wizard and the activity itself is a bug that needs to be fixed. Tab-delimited text files are a thing and should be treated as such. Changing the tab to a space is not a solution.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.

Fair point @eric.brenner

I sent it to our issues tracker to be considered as a future improvement to this activity.