Bat file is having strange font

Hi all, I created a bat file to run a workflow as per below syntax but job doesn’t start.
“UiRobot.exe_Path” /file:”Main.xaml_Path”

i added pause to see what is happening and cmd shows strange font as per below image. issue similar to below link, but solution doesn’t work. i am already on notepad++ with encoding set to utf-8. pls help

@rammohan91 @vovivo

i find some junk here, may i know what is that

the syntax is correct but next to .exe and .xaml i can able to see some special characters remove them and try

even the error depicts the same syntax error with filepath

Cheers @tsc1989

hi @Palaniyappan

thx for reply. i know junk characters causing issue, but don’t know how to make junk disapear. screenshot syntax in notepad++, no junk … another thread (link in my post) said to chg encoding to UTF-8 but mine is already at UTF-8. i face this issue even if i use regular notepad. pls help advise, thx


Write that entire path in notepad file and create batch file Instead of writing into cmd. And then run that bat file and it will work.

@lakshman i typed again in fresh notepad. i tried saving .bat with UTF-8 and it still has junk character. then i try back with ANSI and it works. so problem is solved now :slight_smile: thanks for help

1 Like