Automating web form using an excel csv sheet HELP!

I am trying to execute this path and this is the error I get:
RemoteException wrapping System.ArgumentException: Column ‘Last Name’ does not belong to table DataTable. **
** at UiPath.Core.Activities.ScopeActivity.OnFaulted(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)

** at System.Activities.Runtime.FaultCallbackWrapper.Invoke(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)**
** at System.Activities.Runtime.FaultCallbackWrapper.FaultWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)**

I will also attach a screenshot showing what my project looks like, please help if you can as I am utterly confused.

Hi @Caleb_Greenberg

Can u Check whether name contains the whitespacing issues

Can u show the cev file please?

If the naming does not work then try with columnindex method to extract data


Nived N :robot:

Happy Automation :relaxed::relaxed::relaxed:

Hi @Caleb_Greenberg

You have to perform either one of this step to circumvent this challenge:

  1. Check if ‘Last Name’ is present your datatable.
  2. If first step is fine then… check ‘preserve format’ when you fetch data from excel. It often happen due to macros.

Repeat steps above and revert back if you still face the issue.


Welcome to Forums

You can use Output DataTable activity and messagebox to see the output of the Datatable,

Recheck that Last Name is exactly present in the Datatable, even check if there is any extra spaces etc.,

Hope this helps you


I have check for any extra whitespaces which there are none.
I have attached CSV file

Can you explain how you would use columindex method to extract data (using an example or with screenshots, video, etc. )

I am fairley new to all of this as I have just discovered UiPath.
Thanks for your help

I have attached an image, if you look at output I do have Output set as DataTable (I created it using Set Var). I rechecked the Last Name field.

Can you explain where I check “preserve format” as I am new to using UiPath and this type of software in general. Thanks

Check this screenshot

And use read range either Excel or workbook instead of using read CSV

1 Like

Instead of row(ColumnName) u can use row(columnIndex)

Since the Last Name is in first column so columnIndex is 0

So instead of row(“Last Name”) use row (0)

It will work

Hope it helps you

Mark it as solution if it resolve ur query


Nived N
Happy Automation :relaxed::relaxed::relaxed:

1 Like


Enable Has Headers from the properties.

Hope this helps you


1 Like

Okay so I got it to read the name and other fields. Now I have many fields and a more rows on the excel sheet.

Once it finishes with the first row and It pushes the submit button it stops and doesn’t go to the next row or it doesn’t loop back. Any ideas?

Okay, Lol so it still stops after the next row. I thought I fixed it but I didn’t. After it runs through the first row it wont go to the next row. It just stops.

Any Ideas?


Share the screenshot where you struck

And also is it the same error you are facing?


Tes number 2.xaml (37.7 KB)

I’ve uploaded the file. It doesn’t give me an error. It just stops after the first row.
I have attached the excel file as well

Copy of challenge.xlsx (34.3 KB)

Once it hits the last thing keystroke which is “Last Name” it stops and won’t read the next row automatically. If that makes sense

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.