Authentication failed because the remote party sent a TLS alert: ‘DecodeError’

Hi Guys,

I have installed UiPath Assistant on production machine. But it is giving me below weird error.
Does anyone has faced the same issue? Please help me to resolve it?

Error Message: System.ComponentModel.Win32Exception: “The message received was unexpected or badly formatted.”


@supermanPunch @Gokul001 @ushu @Anil_G @Yoichi @ppr @Palaniyappan

Hi @shreyash_shirbhate

Can you check is the .Net framework is upto date? If not update it and check once

Hope this may help you


Hi @Srini84 ,

I see as Version 4.0

How I will get to know if it latest? I think version 4 is latest.

Do we need to restart the VM? Will that be helpful?


Which version of Studio Assistant are you using?



Check below software requirements


Build and runtime information

Company Policy: None


UiPath Assistant 2023.4.3

Microsoft Windows Server 2019 Datacenter 10.0.

@Srini84 Please check above version for the UiPath Assistant.

hi @Srini84

These software details are for Studio. We are just installing the UiPath Assistant on production machine.


Then the .Net Framework needed is 4.6.1 or greater

Hope this may help you


1 Like

Yes I saw this @Srini84

But same version is there on the Dev machine and it is working fine on dev machine.

Do you know how to update the .netframework version?

Hi @shreyash_shirbhate

I reliazed now that the operating system you are using in DEV Machine might be Windows 10 / 11, which is compatible

But for the machine you are getting error is under MS windows Server 2019 Datacenter 10.0 which I don’t see in the compatability list as above

But you can also give a try updating the .Net framework for that you can refer this

Hope this may help you


hi Srini,

We tried it ,
I got the error of
UiPath .net framework could not be installed cannot find object or property

However in the registry when I see it shows the version of 4.8 , but still the same error persists!

Hi @vkalra

This could be an issue with the OS which you are using might be, because this is not in the compatibility list what UiPath has given on software requirements


The “DecodeError” alert in TLS (Transport Layer Security) typically means that there was an issue with interpreting the messages sent during the TLS handshake. It can happen due to a few reasons:

  1. Incompatibility between the TLS versions or cipher suites used by the client and the server.
  2. A corrupted or malformed message received during the TLS handshake process.
  3. A misconfiguration on either the client side or server side causing issues with the TLS handshake.

To resolve this issue, you can try the following solutions:

  1. Verify the configuration: Check both the client-side and server-side configurations for any errors or inconsistencies in the TLS version, cipher suites, or other security settings. Correct any discrepancies that you find.
  2. Update software: Update your client software (web browser, email client, etc.) and server software to the latest stable versions, which might include fixes for known TLS issues.
  3. Check network devices: Ensure that there are no network devices, such as firewalls or proxies, interfering with the TLS handshake by blocking specific ports or modifying messages.
  4. Debugging: Enable SSL/TLS debug logs in your application or use third-party tools such as Wireshark to analyze the TLS handshake process and pinpoint the exact cause of the DecodeError. This information can help you determine if there are any specific configurations or issues that need to be addressed.

Note that troubleshooting TLS issues can be complicated due to the involvement of encryption and various security mechanisms. If you consistently face this issue and are unable to resolve it yourself, consider reaching out to your server administrator or the support team for the software you are using for assistance.

For robot connection, we recommend using only TLS 1.2, and disable TLS 1.0, TLS 1.1, and TLS 1.3.