Attended BOT: Unexpected error message """"Microsoft Office can’t find your license for this application. A repair attempt was unsuccessful or was cancelled. Microsoft office will not exit""""

Hi,

We have an attended BOT, In the middle of RPA processing there is an error message popup stated that “”"“Microsoft Office can’t find your license for this application. A repair attempt was unsuccessful or was cancelled. Microsoft office will not exit”"""

The microsoft license already activated but the error message still popup. We tried reimaging the machine and tried to run the BOT and again we are getting the same error message. Even we tried with new machine also but no hope still the same error message.

Any idea if this is related to UIPATH activities we use. My IT team is suspecting that manual process steps is not causing this issue but this is happening only while running the process.

Attaching the error message screenshot as well

Hi @bagwat87,
Have you tried to use the Repair Tool?

Hi @Pablito ,

we did try this and received below updates

>>>Generating script for Excel Interop repair actions <<<

Deleting registry key: HKEY_CLASSES_ROOT\TypeLib{00020813-0000-0000-C000-000000000046}\1.9\0\Win32

Creating registry key: HKEY_CLASSES_ROOT\TypeLib{00020813-0000-0000-C000-000000000046}\1.9\0\Win64

Setting registry value for key: HKEY_CLASSES_ROOT\TypeLib{00020813-0000-0000-C000-000000000046}\1.9\0\Win64\ to C:\PROGRA~1\MICROS~2\Office16\EXCEL.EXE

Deleting registry key: HKEY_CLASSES_ROOT\WOW6432Node\TypeLib{00020813-0000-0000-C000-000000000046}\1.9\0\Win32

Creating registry key: HKEY_CLASSES_ROOT\WOW6432Node\TypeLib{00020813-0000-0000-C000-000000000046}\1.9\0\Win64

Setting registry value for key: HKEY_CLASSES_ROOT\WOW6432Node\TypeLib{00020813-0000-0000-C000-000000000046}\1.9\0\Win64\ to C:\PROGRA~1\MICROS~2\Office16\EXCEL.EXE

After making these changes we are able to proceed without issue for 2 days and again we got the same error message. Any ideas or suggestions please.

This is really strange. Have you checked if the settings that were applied are still there? I’m asking for this because in the production environment sometimes you need to remember about GPO settings which might be defined on the Domain Controller. In many cases, it happens that settings that were changed on the machine were overwritten by the GPO.

Faced this error during one of our executions. But didn’t get this error after changing the machine.

I think that if this will happen still for the same machine even after applying those setting, you should get in touch with our Technical Support team.

Thank you Pawel. I am raising a ticket with UIPATH and update here on the solution once it is fixed.

1 Like