Attach browser is not working!



Hi,

I am trying to attach a new browser window which is opened by a button click in the existing browser. In the newly opened browser window, I have identified an element and I am trying to click on it.

When I am running the above workflow, After the new window is opened it is going to background and the next click action is trying to perform in the master window and failing as the element will be in the newly opened window.

I suspect the attach browser might not be attaching the. newly opened browser. We have tried adding a delay between the click (In main/master window to open new window) and attach browser, it didn’t worked for us.

Kindly advise us how to use the attach browser correctly to transfer the control to new browser window

Hi @Madhavi_Puliraju

I think you re collaborating the modern activities with classic activities

Is that any error pop its showing while executing the process

Can we have the selector of the attach browser and click activity which you’re using

Regards

1 Like

Hi @Madhavi_Puliraju,

Try using only the classic activities. You can disable the modern activities as below

image

uncheck modern.

Thanks

Actually it has to get the that browser page up front when using attach browser activity

First let’s try upgrading the UIAutomation package and system package on your studio

Go to design tab-> Manage Packages → Project Dependencies → upgrade and install all packages

Or

If that doesn’t work then give a try with GET ACTIVE WINDOW ACTIVITY instead of attach browser
https://docs.uipath.com/activities/docs/get-active-window

Cheers @Madhavi_Puliraju

2 Likes

I did not find the Modern Activity in the studio. I am attaching the screenshot.

Here are the screenshots for attach browser selector and click activity

Hi!

Currently you’re using modern design experience so you won’t see the show modern because you’re already using.

Could you please mention the error?

If you wants to use classic only for this project please make the changes and use only classic activities. turn off the modern design experience now you can only see the classic activities.

attach browser available inside the classic activities. inside the attach browser you’re using some of the modern activities. there might be a chance of throwing the error.

Make the changes and use only classic activities. this time it won’t throw any error

Regards,
NaNi

Thank you @Palaniyappan @pravin_calvin @Shikhar_Tandon @THIRU_NANI for helping me to find the solution. It really helped me to solve this issue. First I have updated the ui automation package and system package in the studio. I have used the “click” activity under classic section instead of “click” under Application and then I have used the attach browser activity with some delays then it started working. Here are some screenshots of the solution.




This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.