Assignment 1 level 3 - Cannot find the UI element corresponding to this selector

I’m having trouble with level 3 Assignment 1, it keeps showing the error "Cannot find the UI element corresponding to this selector: " for activity System1_close. I’ve been googling with no success. I have already implemented dynamic selector with wildcard - but I still get the same error. How can I solve this problem?

I faced the same issue @M_B1, But it seems the selector is not recognizing the value log out there. I just left it. You can use retry scope to try for two or three times inside a try catch and then just close the tab. I hope someone will help us with the solution

A part of the Selector for the Logout button is missing.
The selector that you have in your error message is for the outer chrome window which is the parent of the LogOut button, and it is not the selector for the Logout button.

What is the selector for the Logout button? Can you please post it here?

You should see something like this. I’ve modified the original selector generated by UiPath with the “*” wild card. As you can see, it validates to True.

1 Like

Thanks for trying to help!
I think the problem somehow is with this Attach Browser because my selector for LogOut button looks fine (very similar to the one presented here).

Hello @M_B1,

I would try to wildcard the parentid. If the CSS changes in the future, it’s likely that the selector will fail again.

Also, I always use an Attach Window first that covers the first part of the selector by defining the parent window. And all other activities are defined within the scope of the Attach Window container.

I’ve had success with this approach. To make the entire module reusable, I parameterize the selectors so that future changes would mean changing out only the selectors as long as there is no drastic change to the target UI page.

Here is a test rig that you can try on your end:

Main.xaml (9.9 KB)