An error occurred while attempting to establish an SSL or TLS connection during using SMTP or IMAP

Send SMTP Mail Message: An error occurred while attempting to establish an SSL or TLS connection.

One possibility is that you are trying to connect to a port which does not support SSL/TLS.

The other possibility is that the SSL certificate presented by the server is not trusted by the system for one or more of the following reasons:

  1. The server is using a self-signed certificate which cannot be verified.
  2. The local system is missing a Root or Intermediate certificate needed to verify the server’s certificate.
  3. The certificate presented by the server is expired or invalid.

See https://github.com/jstedfast/MailKit/blob/master/FAQ.md#InvalidSslCertificate for possible solutions.

How to solve this issue? Please help.

1 Like

Hi Arnab,

Could you please provide a screenshot of the configuration you have done for this activity i.e, the properties that appear on the properties pane.

Also, please provide the mail server you have configured , the complete address

Hi Arnab,

Could you please provide a screenshot of the configuration you have done for this activity i.e, the properties that appear on the properties pane.

Also, please provide the mail server you have configured , the complete address


Visit Topic or reply to this email to respond.

To unsubscribe from these emails, click here.

Sorry, here is the setting

which version of UiPath you are using ?
Try wiht port 587
Set startTLS option in “options” under properties.

Also, check if you are able to succesfully test telnet to that host and port

telnet hostname port

Thanks,
Arun

1 Like

Not sure why, for me it is asking host nand port. Not as HostDisplayName and PortDisplayName.
Can you try updating the package once.

Is there any problem on UiPath installation?
Do I need to download or install something else?

just the package needs an update , not complete installation,

Same problem on this setting

Did you try if telnet is working.
Execute below command in command prompt

telnet <<Host_Name>> <>

2 Likes

Disable your virus scanner temporarily and try again.

1 Like

so your firewall is blocking it. Thats the reason ui path is not able to connect as well

1 Like

yes it was creating problem because of the antivirus, I have disabled it, now working. Thanks very much.

1 Like

This is mainly due to installation to of the any Antivirus software in your system. Neither you can uninstall the antivirus or change the setting of certificates in your antivirus.

1 Like

Hi Kailash,

Can you help me understand how can I change settings for certificates in my antivirus?

Thanks,
Akshay

Firstly Open gmail account of your credentials and go to security settings and “Turn On” in Less secure app access
Secondly Turn Off/Disabled your antivirus
Then try again

1 Like