After installing Platform.msi, I still get Community version

studio
setup

#1

Hi
I downloaded UiPathPlatform.msi from UiPath website. However, after installing Trial Version, when I start UiPath Studio from the menu shown below, I still see Community Version as depicted below. Where am I doing wrong? It has installed UiPathStudio and UiPath Robot in Program Files folder.

Install

  1. Why it is showing Community Version expiring in 9 weeks?
  2. When I start UiPath Studio, it does not also start UiPath Robot. I have to start it separately and even after that, if I click “Settings” menu of Robot Popup, nothing happens.

#2

hi @abskulkarni , are you using a trial version of Uipath. If the answer is a yes, then with the trial version you would get community version only.

Please have a look at the link below.


#3

Hi @Gourav_Kumar
Thanks for the reply. However, I have also got email with Trial Code. So what is the meaning of getting that code as Community version doesn’t require such code. Where to apply this trial code then?


#4

Also on UiPath Website, there are two links. One for “Platform” (which I downloaded and installed assuming it is trial version) and other is Community (which is supposed to be non-expiring).
The end result after I installed Platform version is: I got community edition expiring in 12 weeks.
This is confusing.


#5

@abskulkarni - if you got the trial code, click on activate license instead of start free and use the trial code there.


#6

Hi @Gourav_Kumar
Thanks. Let me try that. But why my Robot does not start when I start UiPath Studio? Also even if I start UiRobot manually, it gets started in the system tray but when I choose “Settings” menu, noting happens. It should pop up screen where I can connect my Robot provisioned robot in the Orchestrator.
Does activating through trial code, solve this problem?


#7

Try restarting UiPath robot service , and give it a try then.


#8

Hi @Gourav_Kumar
I have restarted UiPath Robot Service. But no luck. After starting UiPath Studio, it still does not start UiPath Robot.

I started UiPath Robot manually. It starts in the tray but still nothing happens if click “Settings”.

UiPath1


#9

Hi @abskulkarni,

Do you have admin rights on your machine?

Please check these topics if you are unable to see the Robot Settings:


Trial is now the same with community if you don’t activate the license.
More info here and here.

The windows installer(.msi) has an option under UiPath Robot: Automatically start client - Running the Robot at Windows startup. This option is disabled by default.
Have you enabled it when you installed the platform(Advanced installation)?

Yes, as mentioned before, it’s CE if you choose the Start Free option. However, after the 12 weeks expire you can renew the Community license at any time: https://www.uipath.com/renew-community-license


#10

The windows installer(.msi) has an option under UiPath Robot: Automatically start client - Running the Robot at Windows startup. This option is disabled by default.
Have you enabled it when you installed the platform(Advanced installation)?

I re-installed Platform msi with all features enabled now.

RPA

But problem is persisting. After all installation, it also created a web site as depicted below:
RPA1

But when I browse, it displays error. So I am unable to setup local Orchestrator as well.

Please help me in solving both Robot and Orchestrator issues.


#11

Hello again @abskulkarni

So, in order for the robot service to start automatically please follow this post:
https://forum.uipath.com/t/how-to-fix-uirobot-svc-doesnt-start-automatically/10275?source_topic_id=10745

If you don’t have acces to it, i will paste here the content:

  1. Go to Start > Run > and type regedit
  2. Navigate to: HKEYLOCAL_MACHINE\SYSTEM\CurrentControlSet\Control_
  3. With the control folder selected, right click in the pane on the right and select new DWORD Value
  4. Name the new DWORD: ServicesPipeTimeout
  5. Right-click ServicesPipeTimeout, and then click Modify
  6. Click Decimal, type ‘180000’, and then click OK
  7. Restart the computer
    Note: This is a global setting for all the svcs

You’ve chosen to install the Orchestrator, but there are a few things to set up. Please check the UiPath Orchestrator Guide and see if you’ve done all the setup correctly:

Let me know if you encounter any issues.


#12

Hi @Ovi
I did all those steps correctly. Although, it didn’t work. Also it neither installed UiPath database in my SQL Server. I am using SQL Server Express edition as it is my single machine. Hope it is not the issue.
Since I don’t have admin rights on my machine, I cannot edit registry. Is this also root cause of all these issues?


#13

Please check this post regarding the Orchestrator error. It may be related:

Regarding the fact that you don’t see the Robot icon when you start Studio, the workaround is the one above. And it’s because now you can install only the Robot as a service on a machine, whitout needing to also install Studio.


#14

I checked the link above. I gave IIS_IUSRS user full control over UiPathOrchestrator2017… folder. But no luck.
Below error is persisting. I had selected 8082 as port while installing Orchestrator feature.


#15

@abskulkarni try installing URL rewrite . You can download the same from below url.

https://www.microsoft.com/en-us/download/details.aspx?id=47337


#16

Could you please share the link from where you got the UiPathPlatform.msi ?I am unable to find it!