Advanced Level Assignment Problem: System error at Initialization. The given key was not present in the dictionary. at Source: mscorlib

I Completed all the parts in the assignment to calculate Client Security Hash. When I run the main Xaml file. I get this error. System error at initialization: The given key was not present in the dictionary. at Source: mscorlib At Invoke getTransactionData workflow.

The Extracted Data Table is showing 92 rows.
The filtered Data Table is showing 14 rows.
It is passed to GetTransactiondata by out_WIList.

I am not sure what is it missing.

Thanks for your help.

1 Like

Hi @prasad10

Looks like you have mentioned something to take from the config dictionary, but it seems to be not available in the config file. Can you share a screenshot of the arguments in the Invoke activity of Get Transaction Data? click on Edit arguments and show me the arguments you have.

1 Like

Thanks for the response. Here is the screen shot.

hmm… that part looks good… I wonder whether you are using the config in the get transaction data xaml file. Is it possible for you to share your solution as a zip file so we can have a look? (521.0 KB)

Hi @prasad10

You got multiple problems.

  1. You have added the login, navigate to work items and data scraping under the first run sequence. Which is fine in a way. What’s wrong here is, you have also added the login in the InitAllApplications.xaml as well. So basically, you are trying to login twice which is wrong. So remove the login part from the INITAllApplications.xaml.

  2. The error actually comes from this actvity.

    In this activity, if you click on collections property, you will see that its looking for a config item.

But in your config file, under settings sheet, this is not there.
You have to add it. By default it is there, may be you must have deleted it :slight_smile:
So it should look like this

Once you do this, it should work for you :slight_smile:

Let know whether this works, if it works, please mark my answer as the solution too…

Thanks. That looks like solved that part.
This is the new error.

yes… you are getting that error because in the Extract-DataTable xaml, the argument direction is wrong.

It should be Out argument. Because it is now set to In, the filtered results do not get into the main workflow. Because of that, you get this error in GetTransactionData.

So change it as an out argument and you are good :slight_smile:

I changed the argument to OUT.

Once you do the change and save it in extract-DataTable.xaml file, it gets updated there. but it does not automatically reflect in the invoke workflow activity which you are calling it. It still remains as In. See below.

So what you have to do is, you have to click on Import Arguments button again to reflect the change. Click on it and provide the WIList under value again as it will be blank and click OK.

Then try running again… it should work…

Thanks. I did that and ran it again.

This is the new OutPut

Your argument assigning in GetTransactionData is bit wrong bro…

The data of the out_TransactionItem should be assigned to TransactionItem. that’s why it is not working…

and out_Transactionitem should be a datarow type. Not string. You should pass the entire row here, not only the WIID

Change those and you will be able to pass through to the process state

I made the change. It is proceeding to the next error.

It is throwing this error in Init.

you are not assigning it properly… You have to assign the entire row to out_TransactionItem

like this

and one other mistake… the transactionNumber should start from 0. So in here, you have to remove the -1 because it is starting from zero

This error is after I changed that.

check my post again…

I was also doing some changes along with your chat to see where things are wrong… This will pass the data to process state without any issue… (523.5 KB)

compare it with yours and see…

I was getting attach browser errors. I am working on fixing it.

I will check your updates.
Thanks So much for your help.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.