Add sign on pdf using X &Y coordinates

Is it possible to add sign on pdf using X &Y coordinates. Pdf is structured everytime.
If yes then how? I want to run this process unattended mode. Currently i’m running this process in attended mode it was working fine i used foxit pdf editor application, but the requirement has changed now they needs to run this bot in unattended mode. bot is failing at click activity, send hot keys & Type into. I tried simulate click & send window message both. But it wont works

Hi @pravin_bindage

You can use UiPath’s “Add Image” activity to add an image or signature to a PDF file

you can also use UiPath’s “Get Position” activity to get the X and Y coordinates of a UI element


But this epsilon package is not available for windows projects

Get position wont select signature line it selects whole pdf page

Yes @pravin_bindage , You can try this in Legacy

Do you have any idea? @Rahul_Unnikrishnan @Aakash_Singh_Rawat @Kalpesh_Chaudhari @mohiniganesh15 @vishnuvarthanp @sangeethaneelavannan1 @ppr @Kaviyarasu_N @arjunshenoy @supermanPunch @Sudharsan_Ka @Anil_G

I’m still looking for solution. @Yoichi do you have any idea? please help me…


Can you share the pdf as file?


yes shared in personnel


In the latest UiAutoamtion package, we can use ComputerVision method. It enables to point “Date and signature” then we can click offset point from it using HardwareEvent mode. Does this work for you?


Yes it highlights that fields while we use CV click, but the problem is this process won’t working in unattended mode. My ultimate aim is to Migrate this process into unattended mode.

Thanks for your response…

For now, can you try to take screenshot when error occurs (or doesn’t work as expected)? There is possibility something wrong with screen/desktop.

1 Like

I run this process from orchestrator from local machine. This process is deployed on virtual machine. When i minimizes the virtual machine window it pauses at that point & when i reopen that vm window it resumes. Its not failing its pausing at that point. Now I didn’t get any error when i minimizes vm window.


Did you already check the following document? It might be necessary to edit registry of RDP client.