Access to the path...denied

Just after installing StudioX and receiving this error when trying to create a Blank Task. Any help would be appreciated.

Hey @cmckeown - when you were installing the UiPath StudioX - do you pick the Stable or Beta version?

If this is a work PC, then it might be that you require admin privileges to install the software?

You might need to uninstall and re-install just to see if the same problem occurs

@cmckeown firstly welcome to the community.
Okay so here is the link How to download Studio X Community Edition?

Just uninstall the version you have and reinstall it by following the steps in the link. Sometimes there are things that are missing in documents of uipath so you can take help from here.
After doing this, give your feedback.

Hi @Craig_Bannerman - I installed StudioX via the UI Path Academy. There was no option to choose between Stable or Beta version. Whilst I am using a work PC with quite strict admin policies, colleagues have not had the same issue as me.

Unfortunately, I have tried uninstalling and re-installing but the same problem exists.

Hi @nashrahkhan - Thanks for the reply. After re-installing the download, I still have the same issue. The problem seems to be that the package - ‘C:\Users\cmckeown.nuget\packages\microsoft.extensions.configuration.abstractions\3.1.6’ - does not exist on my machine.

@cmckeown go to settings-> Mnagage sources. Do you have these packages.


It appears I do not have the MS Visual Studio Offline Package

Hey @cmckeown - no idea why that would be missing.
Maybe try downloading VS Code (it’s the Lite Version of Visual Studio)
It should install those offline Nuget Packages to that same location.

It’s free to install. Let me know if that does the trick.

Thanks

@cmckeown okay try to install this offline package by browsing it and then add it in highlighted part.

Refresh uipath and then check if you receive the same error or not.

Hi @cmckeown

Please let us know if the issue was eventually resolved. It looks like some issues with your machine permissions to that folder and/or the specific package feeds.

Hi Maciej,

Unfortunately, I could not yet resolve the issue. Yes, I believe this issue relates to my machine permissions, which I am currently trying to resolve.