Access Denied in network drive when saving files or attaching files to email

studio
p_qa
permissions

#1

Scenario:

When UiPath initializes a program, it seems to load it with different access rights than the user it is logged in as.

For example, when I manually open up notepad, then have a robot save it to a restricted network location for which I have write access, then the file saves successfully. However, when the robot opens notepad and saves to the same location, it throws an error that access is denied. An error is also thrown when a robot opens notepad, then I manually save to the network location. The same error occurs when attempting to attach a file to an email from a network location

Write access has been verified to the directories. There is no problem editing Excel files in the same directory, or moving files from the local hard drive to the network location.

As a workaround, we have been saving to the local computer C:\temp and then using the “move file” activity to move to the correct location on the network drive as part of the closing activities within workflows.

Steps to reproduce:

Saving a file to the network drive by typing in the full file path in the ‘save as’ dialog box. Example: \Server\name\location\filename.pdf

Studio/Robot/Orchestrator Version: 2017.1

Here is an example of an error that popped up when trying to send a PDF stored on a network drive as an attachment in an email


#2

Hi Dave,

We are trying to reproduce, but i can open and then save a notepad file to the network drive. What’s the exact Studio version? 2017.1.6522?


#3

Studio version is 2017.1.6435

uipath studio version


#4

Hello,

thank you for your inquiry,

is there any way to open that specific folder before you start saving, and second is 12-Dec the name of the file, whats the extension?

if its not the filename then try to get inside that folder like “2017\12-Dec\file.xlsx”

Let us know,

regards.


#5

The %12-Dec\ is the directory. It may have something to do with the UiRobot.exe needing elevated access, but am not 100% sure. Our access management team has attempted to fix it on our end as that’s where the problem likely lies, they’re just not sure where to start.

I am able to open files and save them from within the network drive. I can also move files to the network drive using the “move file” or “copy file” activities. However, when I try to save a new file to the same network drive using a “save as” dialog box, I get the error that access is denied.

I’ve also noticed that when UiPath opens an application (e.g. notepad.exe), that when I open up the “save as” dialog box, the network drive names and the user “Libraries” folder names disappear as seen in the below 2 screenshots

robot openeduser opened


#6

perhaps, you need to use the drive letter, even when this is a little out of the automation becuase, you know , in case somebody change this you will have to do the same in UiPath.


#7

Is the robot user different than your user?


#8

No, the users are the same - this is for a studio/dev robot. The screenshot was just showing who initialized the program (robot vs user)


#9

I was unable to save on this folder " \co\co\RPA_DEPLOY\20-12"
until I mapped

image

weird right.!?


#10

I was unable to save on this folder " \co\co\RPA_DEPLOY\20-12"
until I mapped

Can you explain a little further what you mean? Also, you’d have to type in to leading \\ at the beginning so it’d be "\\co\co\RPA_DEPLOY\20-12"

The drives are already mapped as shown in the pictures posted (H:, J:, L:, etc). Do you mean they need to be remapped?

I’ve also tried saving using the mapped letters, but I get an error that the file path doesn’t exist. This even happens when physically clicking through to the location and you can see files within the directory (see picture below). It appears that this is happening because when UiPath tries to save it looks at Z7LPC04SUVY L:\RPA\example\example.txt. Z7LP04SUVY is my computer name
However, when a user saves it shows Computer L:\RPA\example\example.txt It doesn’t show the computer name in this case and just displays the word “Computer” instead
user


#11

I still haven’t had any resolution for this. It seems so strange that moving files into the network drive works just fine, but saving a file there from an application like notepad.exe doesn’t work.

I’m wondering if it is perhaps because the UiPath Robot Service is logged in as a Local System Account?
UiRobot Service Logon property

I tried changing the settings so it logged in as “This account:” using my login and password, but then a different error popped up when trying to run any programs with the robot