Access to the path denied in save mail message

Hello teams,
suddenly, since yesterday, my UIPath robot is no longer able to save attachments and e-mails via outlook activities on local folders, on my pc. I tried different paths, including the process documentation itself. The system always gives me the same error in denying access to the path. I didn’t make any changes on windows, apart from downloading and installing the latest updates. All my folders have always been in read-only mode, but I’m facing this problem since yesterday. I Use Win10 and Outlook 2016. Does anyone have any ideas about this? Thank you so much for the help.

@VALMAN

Run UIpath studio as admin and check once.

Hi @VALMAN,
Please check also path permission.

Sorry for my ignorance, Pablito, what’s path permission? Ty!

Oh sorry… It’s my fault. I meant the permissions to the folder. Read, write etc.

I tried this very moment and system gives me the same error. Here messages from error details log, i hope this can be meaningful:

UiPath.Ipc.RemoteException wrapping System.UnauthorizedAccessException
Server stack trace:
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
at System.IO.FileStream…ctor(String path, FileMode mode, FileAccess access, FileShare share)
at MimeKit.MimeMessage.WriteTo(String fileName, CancellationToken cancellationToken)
at UiPath.Mail.MimeMailService.SaveMail(MailMessage mail, String filePath)
at UiPath.Mail.Activities.SaveMail.<>c__DisplayClass11_0.b__0()
at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object args, Object server, Object& outArgs)
at System.Runtime.Remoting.Messaging.StackBuilderSink.AsyncProcessMessage(IMessage msg, IMessageSink replySink).

Thank you very much again.

Based on this error for sure Studio has problem with permission to the folder. You said that problem started yesterday. I know that it might be the silly idea but have you tried to restart computer?

No silly ideas. I restarted three times, i tried Microsoft procedure for changing permissions on folders too from command prompt. All unsuccessfully. Can’t understand why. Ty Pablito.

Hmm last thing I have in my mind. Please open completely new project and do just basic activities to catch email and write attachment to see if it will work when done from scratch.

bro did you try using another folder?

I just had this issue too - I found this post and it solved the problem.

3 Likes


I am running a process which is trying to save a mail into a specified folder. but i am getting the exception. Have tried changing the directory but no use.
I have started working on new system recently which is windows 10. I tried checking the folder properties which shows “read only” and doesn’t get unchecked manually(keeps returning to read only enabled). I tried checking the permissions for the folder and found that ‘full control’ previlleges are available to the user.

Can’t get to the root cause of the issue as well as any workaround to get this working.

Hi @Abhishek_715,
Is your user account an administrator? Try to open UiPath as Administrator and check then?

Yes ,my account is the admin has full control.

I still have the same problem, in win10, no matters the updates installed. I don’t really understand why.

What about this:
image
Is “new” a folder?

Yes new is the folder created.

Can you check security settings for this folder?

It has ‘Full control’ defined for each entity

Hmmm very strange. Last thing I have in my mind is to try to run Studio as an Administrator.
image