Abby Cloud OCR Exception

I have tried to use the “Abbyy Cloud OCR” activity to read a PDF file.

It keeps throwing an exception.

Any input will be really helpful.


Please find my sequence as below.

Abbyy Cloud OCR ServerUrl Property set to

Exception thrown
Source: Abbyy Cloud OCR

Message: Error performing OCR: AbbyyCloudErrorRunEngine

Exception Type: System.Exception

An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is:
System.Exception: Error performing OCR: AbbyyCloudErrorRunEngine

Server stack trace:
at UiPath.Vision.VisionProcessor.ScrapeUsingHostService(OCRInput input, OCROptions options, CancellationToken cancelToken)
at UiPath.Vision.VisionProcessor.Scrape(OCRInput input, OCROptions options, CancellationToken cancelToken, Boolean useHostProcess)
at UiPath.Vision.UiImage.ScrapeOCR(OCROptions options, CancellationToken cancellationToken)
at UiPath.Core.Activities.OCREngineActivity.<>c__DisplayClass36_0.b__0()
at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object args, Object server, Object& outArgs)
at System.Runtime.Remoting.Messaging.StackBuilderSink.AsyncProcessMessage(IMessage msg, IMessageSink replySink)

Exception rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.EndInvokeHelper(Message reqMsg, Boolean bProxyCase)
at System.Runtime.Remoting.Proxies.RemotingProxy.Invoke(Object NotUsed, MessageData& msgData)
at System.Func1.EndInvoke(IAsyncResult result) at UiPath.Core.Activities.OCREngineActivity.EndExecute(AsyncCodeActivityContext context, IAsyncResult result) at System.Activities.AsyncCodeActivity1.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

try it withouth the server url

Tried without providing the server url. Getting the same error. Are there any packages to be included?

no, it works fine for me but i have a an account that don`t require a server.

I too created an account today with Its a 3 months trial.

Its working fine. I am sorry, It was a mistake from my side. Given a wrong password.
Thank you for the support

Hi, im getting an execution error, can anyone provide help?
I have the user name/password/url however it does not work.

Hope you created created an account with
And an application too. It would have sent you an password through mail.
In Abbyy Cloud OCR engine property, you need to specify the application id, password and url as


Regarding the Abby Cloud OCR i m trying to use but same error. I have given the application id,Password which was sent in mail, the server url. But its not working…

Could you please help me.


Hi Sneha,

Not sure what is the issue. If you provide the correct app id and password along with the server url, it should work. Please refer the activity property that I tried.

Since, my app credits are expired, I am not able to test it. Though its showing credit expired error and not the one earlier I got.
Please make sure that the password is correct one. (no trailing spaces if you are doing a copy and paste)

I am using Abby Trial account and created an Application from there i got applicationid,password,serverurl

Yes… I too was using trial account. Did you cross check the password? Can you post the property snapshot hiding the password?

1 Like


Not getting any clue. While creating the application in cloud, I selected the Location: European Union. Will that be of any help?

1 Like


Thank you so much it worked for me when i choosed European Union…


Superb. All the best. Have a good day ahead!

1 Like


Hello, I meet the same problem, but i use your solution,but it doesn’t work.