A form created with the Form Designer is not displaying on a specific PC

I have recently encountered an issue with a form I created using the Form Designer. For some reason, the form is not displaying on a specific PC.

  1. The form was designed and saved correctly, and it is working fine on other devices.
  2. The PC in question has up-to-date software.
  3. I have tried restarting the computer and clearing the cache, but the issue persists.
  4. There are no error messages or warnings displayed when attempting to access the form on the problematic PC.

Has anyone else experienced a similar issue or can provide any guidance on how to resolve this? I would really appreciate any input or suggestions from the community.

Thank you in advance for your help!


The following topic seems similar. Can you check it?


@Brian_Choi is your issue similar to what is mentioned in the post here? UI Glitch on Taxonomy Manager and Forms - Feedback / Activities - UiPath Community Forum


Thanks for the suggestions.
The window is not blank, it itself is not showing up.
Job started processing, the progress circle spins forever without any error message.

I found that when I run the automation, the executer runs but UiPath.OutOfProcessUi.ServerHost is not running on that PC.
I tried to install/reinstall/repair various versions of .NET runtime/desktop runtime/sdk but had no luck.


Hi @Brian_Choi ,

Could you also provide us with the Dependency versions that are being used in your project ?
Also maybe along with the Studio Version.


The studio version is 2022.10.5

it will maybe independent to the original issue but take a note on the red marked System.text.Re…ssions package.

It is not needed to reference it. When used a regex

  • use the full qualified name within the statement
  • import it to the namespaces:

taken from: