21.4.4 - issue with UI element detection

new update not stable, we are getting any where error just like (selection not visible,selection no longar valid)

any option for this error

@Ram_Gurav1 when are you getting these errors? When using any specific activities? Can you please share a screenshot?

getting below error

The bot stopped at following activity:
Type Into Order No (CSO header)
The following error occurs:
The UiElement is no longer valid
please see in attached image CSO No text box is active but still getting error from uipath

The bot stopped at following activity:
Click Before type CSO
The following error occurs:
Error HRESULT E_FAIL has been returned from a call to a COM component.

The bot stopped at following activity:
Click Before type
The following error occurs:
Cannot get the screen rectangle of this UI node. A possible reason might be that the element is not visible.

please suggest what to do for above all errors from last update we are getting this error any where

@Ram_Gurav1 what version of UIAutomation.Activities package you had before upgrading to 21.4.4? Thank you

@Ram_Gurav1
Can you share a screenshot of your project dependencies with the UIAutomation.Activities dependencies expanded? Something like:
image

any solution reached for this? similar error for me

@seetharaman what Studio & UIAutomation package version do you have? Have you upgraded from a specific UIA version? Can you share your project dependencies? And what is your use case and error? Thanks

I think I have the same issue.

UiPath studio version was recently updated on vdi to 21.4.4 and robot made at the start of the year when we had older version, might be October one started failing to identify UI elements in MS Dynamics unless I log on to virtual machine.

Previous process dependency version:
“dependencies”: {
“UiPath.Excel.Activities”: “[2.9.3]”,
“UiPath.Mail.Activities”: “[1.9.3]”,
“UiPath.System.Activities”: “[20.10.1]”,
“UiPath.UIAutomation.Activities”: “[20.10.6]”,
“UiPath.WebAPI.Activities”: “[1.6.0]”
},

Currently tried updating to new ones, but did not help.
image

Tried a lot of suggestions in the forums and from UiPath website LoginToConsole and RemoteDesktop_SuppressWhenMinimized and reinstalling RdpClient extension to no luck… Seems like in some threads this problem is also mentioned, but no hotfix or quickfix yet…

https://docs.uipath.com/releasenotes/docs/uipath-ui-automation-activities#:~:text=Known%20Issues,initially%20installed%20Studio. seems like something related…

@gendalfas I suspect a mismatch of the UIAutomation.Activities package. Can you post a screenshot with this package’s dependencies, similar to mine above?