20.10 - Opening Workflow - An internal error has occured. It is recommended to restart UiPath Studio

Hi.

I’m trying to open the workflow that worked fine in previous version, but it gives following error.

image

I need to work on with workflow urgently. How to solve this problem?

Kind regards,
Vanja

Hi @vanjav, have you updated Studio from 20.4.3 to 20.10.0?

  • Do you experience this issue only with 1 workflow, or all of them?
  • Do you see all the Studio settings in the Backstage?
  • It would be really useful if we could get the Diagnostic Tool report from you. You can send it via personal message to me, @Pablito or @loginerror.
    You can find the steps for generating the report here: Studio Community installation progress gets stuck
    After that, please try and cleanup your environment by using the steps provided in the above link.
    Kindly let us know what happens.

Hi @coramia,

very kind of you for prompt reply. Thank you.

  1. Yes, it was updated from 20.4.3. to 20.10.0.
  2. I started 4 WFs, only one of them is making an issue.
  3. Yes, error pops-up when starting Studio.

4.a Before getting your answer I already deinstalled Studio (which was installed in december 2019) and installed new Community Cloud Studio stable version. I only did not clean the folders before installing the new one.
4.b I will send you the Diagnostic Tool Report as a personal message.

Kind regards,
Vanja

1 Like

Hi @VanjaV, thank you very much for the details. I noticed something in your screenshot above:

  1. can you please show us if you have any templates available? It’s the New from Template section in the page above:

  1. can you go to the Settings page and show us if, for example the language is correctly set?

  1. you mention that you installed the previous version in December 2019 - i assume you are talking about 19.12.0-preview, is that correct? you first uninstalled it, then installed 20.4.3 and then upgraded to 20.10.0?

Can you please try and cleanup all folders as mentioned in my previous post, then install Studio 20.10.0 and see if your projects can be opened correctly?

Thank you so much for your collaboration.

Hi @coramia,

Some more details:

  1. I am using Windows 10 in english, .NET Framework Version 4.8.03752

  2. I deleted the folders and I re-installed UiPath Community Cloud stable version

  3. Newly installed Studio is showing this templates (I didn’t use any of them):

  1. This is my Settings Page:

image003.png

  1. We installed UiPath in december 2019, it was then upgraded by UiPath until 2 days ago. Last update was from 20.4.3. to 20.10.0.

  2. And YES, the problem still EXISTS:

image005.jpg

Thank you for helping me.

Kind regards,

Vanja

1 Like

Hi again, @VanjaV and thank you for your details.
Our team is already investigating the issue, but I would kindly ask you one more thing until we manage to isolate this.
Could you please send us the project.json file of the process you are trying to open that triggers the error? Either via a private message or attach it here, if you feel comfortable.
Thank you so much once again.

Attached.

Regards,

Vanja

project.json (4.82 KB)

Hi @VanjaV

Thank you for all the assistance. I believe we have some steps that you can take to fix the issue.
Naturally, we will shortly release a fix that will take care of it, but this should get things working in the meantime.

Please do these simple steps:

  1. Close your Studio
  2. Navigate to this location:
    %localappdata%\UiPath\app-20.10.0\Profiles
    
    Depending on the channel, either Stable or Preview, the path might be this one:
    %localappdata%\UiPath\app-20.10.0-beta1145\Profiles
    
  3. Now, open the .json file of your current Studio profile (typically Studio Pro) with a Notepad and edit this line like so:
    image

Thus, set the EnableObjectBrowser as true.

  1. Open Studio and try to open one of your projects. This should fix both the opening of the project error as well as missing settings issue.
2 Likes

Hi @loginerror,

there are 4 JSON files:

image

I checked all of them. In Development and StudioPro it was already set to “true”,
in Business and Console I changed from “false” to “true”.

image

The problem still exists. :frowning:

2020-10-19_Studio_public.txt (114.0 KB)

Kind regards,
Vanja

1 Like

Does it help if you then:

  1. Close your Studio
  2. Close your Assistant
  3. Navigate to here:
    %AppData%
  4. Rename UiPath to UiPath_Backup
  5. Try to run Studio then.

It could be that the UiStudio.v2.settings in this folder needs to be re-created from scratch, which will happen when you rename the UiPath folder.

There is one more suggestion that can help - if you have the .objects folder in your project, deleting it might help.

2 Likes

I deleted the .objects folder and it WORKED! :slightly_smiling_face: :upside_down_face: :slightly_smiling_face:

Many thx for your help!
Kind regards, Vanja

2 Likes

I’m happy that the issue is resolved. A fix is coming of course, so that this workaround will only be needed for a short time.

For anyone else with the issue, please see this topic:
Fix to the issue of opening projects / creating new projects / missing Studio settings

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.