Wrong comma/thousand delimiter/seprator

My data source is a simple .xlsx document:

Untitled2

As you can see, I use comma as decimal delimiters (and . as thousand seperators). And I want to keep it that way.

When I execute this workflow:

It gives me a result, where it suddenly uses “.” instead of “,” as comma delimiter What is wrong? This is only the case on this machine. On my 2 other machine it doesn’t change it.

This is my Windows 10 settings:

And this is my Excel settings (I’ve also tried to untick “Use system seperators” and type them in manually.

I’m interested in a working solution and not a a workaround (like using replace each time etc.).

Please help :grinning:

Hi,

Can you try to put Assign activity as the following at the beginning of your workflow?

System.Threading.Thread.CurrentThread.CurrentCulture = new System.Globalization.CultureInfo("fr-FR")

Regards,

2 Likes

Yep, then it works. But how do I solve it without having to put in an extra assign in each of my workflows?

@LauraMM
have a play with the preserve format setting (read range)

Sure, but then it’s another workaround. I want to understand, why it doesn’t work on one machine, while the two others works perfectly. All same settings (or at least I think).

@LauraMM
technically, internaly a double has defined the decimal seperator as “.” and thats all
the locale representation (e.g. yours) is defining the group seperator with “.” and a decimal seperator with “,” when the double is to be represented as a string.

Regardless on how we want to represent the double as string, internally it rest as it is implemented, is fixed and we do not change.

So, if the locale / different representation of the double is not specified (e.g. via CultureInfo…) then the internal representation will be used. And this is the correct behaviour.

Same we do have with dateTime (internally in the format of MM/dd/yyyy HH:mm:ss and we do not touch the internal structure)

1 Like

Hi,

If we can change its behavior by some settings except project / workflow, interoperability of project/workflow among PC might be lower. Unfortunately, for now there is no culture settings in project settings etc. it’s not recommended to change it even if we can change it by any other ways except workflow, I think.

Regards,

Ok, but why is there a diference on this machine only and not the two others?

It seems like a pseudo-solution to be honest.

@LauraMM
lets continue the discussion once you have checked all the technicals e.g. here:

then we can base on facts and sort it out

Yeah, is here any particular paragraph, you think will solve my question? I can’t really find it.

My problem: I have the same settings on 3 computers and yet 1 of them behaves in a different manor. I’m not interested in workarounds or pseudo-solutions.