Writting a post and then attaching an image leads the text to disappear

This happened to me 1 minute ago, while reporting a bug in Studio. I wrote a long text and then, when I attached a screenshot and clicked on the “Create Topic” button, it complained the post has to be 100 characters (or words?) at least. Then I realized the text was not there anymore, being it replaced by the attached picture text.

Thankfully I tried ctrl+Z a couple of times and I got my text back. I placed the cursor in a different way, uploaded the picture again and this time it worked properly.

Hey @pere

Was it by chance that some text was selected?

The way it works is that it will replace some text, if you paste an image, like this:

Otherwise, if that was not the case, then I think it might be a bug.

I’m not aware of having selectd anything. Just a bunch of text, then the cursor at the end, probably without any further new line jump. Uploaded some attachments, their respective texts replaced my long text. But who knows; probably it needs further testing.

Definitely this is A BUG; it happened to me again just one second ago. I assured no text was selected, and the cursor was below the written message. Just select a picture to upload, and that’s it - the written message disappears. And this time it was even worser, as ctrl+z didn’t bring it back. Thankfully, I had copied the text to clipboard before doing anything, just in case…

I have trouble reproducing this. Any chance you could record a small video of how exactly it happens?

I tried all three ways of uploading an attachment:

  • via the menu button
  • via the ctrl+v
  • via drag and drop

In all cases, it correctly places the upload (be it an image or a file attachment) at the cursor location.

Any additional details would be much appreciated!

I have always done it through the button.