Write Range not working from data table

Hi,

I apologise ahead of time if this is a stupid error on my part.

I have a ‘build data table’ I would like to ‘write range’ to an excel workbook.
I have a sequence if a file is not found to create the data table and write to Excel.

I have other write range activities in my sequence from a data scrape later on that works fine, which makes me think I am missing something

image

Thank you for any advice

whats the error message?

There isn’t one.
The process goes through however the excel sheet is blank

could you post your sequence + excel file here?

i see in your build data table activity that you have no values inside, only headers,

If you didnt tick “add headers” in your write range activity, the excel will be blank, if you ticked “Add headers”, then you will see the table headers in excel.

This is the properties of that write range
image

No headers though in Excel.
If I add an output data table > write line, I can see the headers this is why its weird

do you at least see headers in the excel sheet? or is it completely blank?

completely blank

do you mind uploading the sequence here?


apparently write range doesnt allow empty dt to add headers in the old version. in this post the person upgraded to the latest excel activity and it worked…

Test Seq.xaml (8.0 KB)

This is just a hotfix (add empty datarow), but i think this bug should have been solved in the latest version of excel activities

image

2 Likes

@jack.chan

You’re a LEGEND

Thank you for that, it was driving me crazy.

I have updated to latest excel activities 2.9.4, however that didnt’ resolve the issue. Your fix did though

Thank you very much

1 Like

Youre welcome :slight_smile: please mark my reply as solution

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.