Write Range error of Workbook

Am trying to read a range from one workbook and writing the range in another workbook.
But i get an error saying:
Write Range: Index was out of range. Must be non-negative and less than the size of the collection.\r\nParameter name: index

Below is the screenshot of sequence. Pls Note: I dont want to use excel scope application. I would like the solution usin workbook activity.


@Palaniyappan @Dave @loginerror @divyagupt @aksh1yadav

are we using same excel file to be updated
if so use a KILL PROCESS activity in between these two activities and mention the process name property as “EXCEL” and then try once pls

Cheers @hss

Hi @Palaniyappan No the reading and writing are of 2 different files.

If that is a excel file try with a excel application scope and a write range within it (not from workbook activities)
Cheers @hss

@Palaniyappan yes… using excel scope it works. But my use requires me to use workbook… Hence looking for a way outta this error

do we have any specific reason to give up a reliable method especially when we have a excel application installed

@Palaniyappan excel is not installed :slight_smile: thats why this struggle

did this error repeat after placing KILL PROCESS between these two activities
Cheers @hss

@Palaniyappan Yes error still persists

i wonder why this comes up
because in write range the only way for index is with the range, its mentioned correctly
then another chance is due to the application is already opened and we have used kill process as well
hmm…kindly recreate once this better with a restart of studio
not sure this would work, lets try

Cheers @hss

@Palaniyappan Yeah the negative range part even i didnt get… but restarting didn’t workout…

Try with excel application scope once and check if that is working @hss?

@HareeshMR The use case require me to use workbook activities only… Hence not using excel scope… :slight_smile:

Both will do the same purpose right @hss? :slight_smile: . But if it is working fine, then we can debug the issue where it is going wrong. so just asked to try it once

@Hareesh… Do u mean workbook activities inside excel scope… or do u mean an exclusive excel activities thing?? Coz the former wouldn’t be correct and the latter works.

Just excel application scope and inside that , write range activity which is related to application integration.excel.write range @hss

@HareeshMR yeah that works…

Hi, Anybody have solution for this issue. I am using workbook - Read Range activity and I am facing the same issue. Kindly help.


Hi to all.
I had exactly the same issue with the write range activity.
Just I didn´t got the content from another excel range than from a DataTable.

Definitely not the nicest solution but worked in my case, I had to delete the whole sequence and build it up again the same way. It worked :wink: Unfortunately not the first time I had to fix issues like this with uipath in that way.

@hss … did you tried builung it up again?