Write CSV with LF endline (Unix) and UTF8 witout BOM

I’m tring to make CSV with UTF-8 encoding (without BOM) and UNIX new line. Delimiter is Pipe.
I read: Small Bug - Read & Write Text UTF-8 encoding - #6
I installed newest package: 21.4.0 for System.Activities and 2.10.4 for Excel Activities.

When I use Write CSV activity with properties:
Delimiter Pipe
AddHeaders True
Encoding: “utf-8”

I am still getting UTF-8 BOM. I tried also with empty value. It didn’t worked.

How to get csv with UTF-8?
How to change newline separator from /r/n to /n (CFLF to LF)?

Nevermind - I just found solution. I convert datatable to string, with Pipe as delimiter and vbLf at the end of each line. Next I used write text file activity

Thanks, but that will not help me. I have DT with thousands of lines. I wanted to write it as csv to import to specific system that requires LF sign at the end of each line. Write CSV activity doesnt has option to choose end line. So I need to use write text file and in this case simple write text file is working (encoding with empty value works fine)

we were not using write csv, as you can see in the screenshots