"Write Cell" Activity Deletes Excel Sheet

excel

#1

Hi, I am using “Write Cell” activity (System > File > Workbook> Write Cell), Sometimes it deletes my excel sheet, Does anyone has faced this type of issue?


#2

hi @ kuldip.gohil

will you please share your workflow?

you have installed any antivirus?

Regards…!!
Aksh


#3

It was a bug at some point when trying to write in A0 cell (which does not exists). Is this the case?


#5

Hi, @aksh1yadav

I am not able to share workflow due to some reason, but you can find screenshot of activity from where its deleting excelsheet.

Antivirus is not installed.

Thanks


#6

@badita - No, its not case here. still will double check by providing “A0” static.


#7

hi @kuldip.gohil

it is really a strange case what is triggering behind in that case. have you tried the same artifact run on different machine? and you are getting same result?

Regards…!!


#8

@aksh1yadav - Yes, I’ve tried in different machine as well and getting same result. issue is random.


#9

Could you attach the xaml and the excel file?


#10

hi @kuldip.gohil

as you said you can not share that .xaml but you can share that demo excel and that excel reading part .xaml only will also be helpful. i guess.

Thanks&Regards…!!


#11

Hi,
This is a known issues that usually occurs when using larger excel files. Could you try using “Excel application scope” with “Write Value” as a workaround, and let us know if it is ok?

Thanks


#12

Hi @cosmin.sandulescu

Excel is small, less than 20 records. I’ve used write cell at many places.

I will try excel application scope as well. but it will take time for me to replace and confirm.

will let you know

Thanks


#13

Hi @kuldip.gohil
I also faced the same issue as you are facing.As cosmin suggested, try using Excel application scope. Additionally put a little delay between the two write cell activities.


#14

I’ve put delay of 2 second between every write cell activities, as of now its working… thanks all… will update if its still not solve problem.