Write access to repository not granted

Hey All,

I am exploring the Git feature with Studio and having trouble with it. Here are the steps that I am taking to push my workflow to Github:

  1. Go to Teams and Click on GIT Init
  2. Select my folder of where my project is at
  3. Click on Commit and Push
  4. Enter in my remote URL for my repository and Clicking Add and Save.

Then I get a message where it says “Write access to repository not granted”

I went into my Git repository and made sure I have the “Read and write permissions” set in the Workflow permissions section. Any ideas of how to resolve this?

@kadenfrazier Mostly I think you should verify that you have the correct repository URL and that you have write access to it. Ensure that you have administrative privileges or that the repository owner has granted you write access. Also if you can post GIT settings screenshot to check.

Also check if the settings has this enabled:

Shantanu Chande

@shantanu_chande thank you for reaching out, this is my own repository so I should automatically have admin privileges, correct? I also looked at my settings and replicated the settings you displayed and still getting that error.

@kadenfrazier Following is a wild guess and yes if you are the owner of the repository, you should have admin privileges.

Go to your local repository folder and find a hidden folder called “.git”. find a file called “config” in the folder as attached below.
enter image description here

check if it is reflecting SSH URL and if not try changing it to it.
enter image description here

I will check for alternative solutions, do you mind sending the GIT Settings screenshot and UiPath Commit/Push error.

@shantanu_chande I went ahead and did the config file and still getting the error. Below is the screenshots:

Is there a particular section of my Git settings that you would like to see?

@kadenfrazier From the error stack it is clear that UiPath is not able to connect to GIT due to access issue i.e 403. Can you take a backup and redo all settings from the scratch.


@shantanu_chande Thank you for that link but I am still getting that 403 error.

Found the solution, I needed to add UiPath to my Github with the link in https://docs.uipath.com/studio/standalone/2023.4/user-guide/managing-projects-git

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.