Working with "CredentialUIBrowser.exe"

My business is using a old version of Dynamics CRM and when logging on to the webpage it brings up a UAC box.

I built out a process on my Dev system and it works fine but once I publish it and put it on my production bot it fails saying it cannot find any UI Elements that match.

I have loaded up UIExplorer on the Production bot to compare to Dev and the setup is the same.

Make sure no person has logged into the VM with the robot account and then just closed the RDP window. This leaves the session active but locked. You have to SIGN OUT from the start menu. I suggest trying that first - log into the VM with the robot account, then SIGN OUT. Now run your automation and see what happens.

Are you sure the prompt is appearing on the screen? I always take and email a screenshot (using Try/Catch exception block) when there’s an error, so I can see what was on the screen.


Just tried it again after making sure all RDP sessions were signed out fully and it still cannot find the application and I am sure the prompt is loading

How are you sure? You should screenshot when the error occurs to confirm.

A trick that might work is to put the activity inside a try/catch. Then in the exception block put a Message Box activity. This will stop the automation and make it sit waiting for someone to click OK.

When it reaches this point you can then log into the VM using the same robot account, and should be able to see what’s on the screen as well as use UI Explorer to verify the properties/selectors is the same.

Forgot to say that I also checked UIexplorer and the elements it found match what had in my process

I’m starting to wonder if it’s a security feature that you can’t interact with it on a server. Is the VM a server version of Windows while your computer is a desktop version of Windows?

Are you using hardware events, simulate, something else? Are you attaching to that prompt with a Use Application/Browser activity? IIRC those prompts are separate from the browser.

My Dev and the Live Bot are both running server 2019 just slightly different patch versions.

I am using Hardware events but have tried Simulate too, I am using a Use Application/Browser activity and yes the prompt is separate from the Browser I have it isolated in its own activity outside of the previous browser one which like i said works Find in Dev just not Live

Just a stab in the dark here, a test to try in order to maybe isolate the reason for the problem - set the robot to Log Into Console and see if it works.

Thanks for the suggestion but unfortunately I get the same error… Originally it was set to Login with Console - No and even after changing to Yes it doesn’t find the application.

I tried doing a Run on my Dev instead of Debug mode and it was fine

And I checked the CredentialUIBrowser permissions in case the bot didn’t have access to it but that’s not the case

Generally you don’t want this turned on.

What’s the selector you’re using for the Use Application/Browser? Is it the Use App/Browser that’s failing, or a click/type activity?

So it is failing on the first activity within the Use application/Browser activity, I am going to try putting in a Export UI Tree activity at the start and see what it outputs

Make sure you take a look at the Window Selector property of that click activity.

Got it working eventually, had to change my selectors from Strict to Fuzzy, even though the selectors were setup the same, must just be a slight variation somewhere.

Thank you for your suggestions and help

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.