Work in CMD but not in Task Scheduler

When I run the following command in CMD everything works:

C:\Users\Administrator\AppData\Local\UiPath\app-17.1.6414\UiRobot.exe /file:“C:\Users\Administrator\Documents\UiPath\Telelink\Main.xaml”/monitor

But when doing the command from the task scheduler I get 2 errors:
Task Scheduler failed to launch action “C:\Users\Administrator\AppData\Local\UiPath\app-17.1.6414\UiRobot.exeC:\Users\Administrator\AppData\Local\UiPath\app-17.1.6414\UiRobot.exe” in instance “{82d58d78-2afc-4761-b582-426c304d7df9}” of task “\UIPath Telelink job”. Additional Data: Error Value: 2147942402.


Task Scheduler failed to start “\UIPath Telelink job” task for user “WIN-C0SHE18Q5NF\Administrator”. Additional Data: Error Value: 2147942402.

What could be wrong?

[quote=“Alex_b, post:1, topic:8648”]

Does the computer has admin privileges? can you launch the task manager as admin and check :slight_smile:

Ok fount the issue.

Had to chance to this setup:

Program script section:

/c C:\Users\Administrator\AppData\Local\UiPath\app-17.1.6414\UiRobot.exe /file:“C:\Users\Administrator\Documents\UiPath\Telelink\Main.xaml”/monitor

Now I tried to move this to the SQL job agent, but with no success. Did you have any experience with this?

Hi @ddpadil
I am Creating a scheduling Process in task Scheduler to automate the certain task at a particular time. In that we have two scenarios
i) run only when user is logged on
ii) Run whether the user is logged on or not.

In the first scenario, it’s working fine. But in the second scenario is not working ?

Is there any Possibilities to work on this issues or this features is supported by UiPath ?
any idea!!!



Can you solve your problem?

I am trying to schedule a task using the windows task scheduler but I have the same scenario that you. If i choose run only user is logged on It works fine however, when I change the option to run whether the user is logged on or not It doesnt do anything.