Issues running inside bat from task scheduler

schedule

#1

I have tried to create a bat that would launch the UIPath flow, but I can’t get it to work from task scheduler

version 1

start "" /min "C:\Program Files (x86)\UiPath\Studio\UiRobot.exe" /file:"D:\ProgramData\UIPath\test\Main.xaml"
echo %DATE%_%TIME% >> D:\temp\test2.txt

version 2

"C:\Program Files (x86)\UiPath\Studio\UiRobot.exe" -f "D:\ProgramData\UIPath\test\Main.xaml"
echo %DATE%_%TIME% >> D:\temp\test2.txt

Both versions run correctly when I double click the bat file, but when I have it as a scheduled task, the flow is not executed, but test2.txt file is modified, so the issue is only on UIPath…

image


#2

Hi @c.ciprian

Weird, I’ve just tested it and it works. I left the Start in (optional) field blank though. The other difference was that I run it from community edition, therefore from my user folder and not program files folder.


#3

Which of the versions do you use to launch it from the bat? Both work for me on double click, but not as scheduled task :frowning:


#4

I’m using the latest Community Edition 2019.1
Have you tried leaving the Start in field blank?