WebDriver protocol and Chrome Profiles

Hello
I try to use WebDriver protocol, and run into a problem. It wants to log in with the Guest account, which makes me have to choose to accept the terms in Google wich block the automation.

If I run with WebDriver disabled, it opens chrome as Profile 1 with no problems.

I’ve tried adding profile path (“–profile-directory=”“C:\Users\XXXX\AppData\Local\Google\Chrome\User Data\Profile 1"”“) and tryied to ad just (“–profile-directory=”“Profile 1””") to Arguments in Application/Browser as recommended here: Studio - Extension for Chrome
Without any luck.

Does anyone know what I’m missing?

Im on Studio 23.10.4

@MiXs

just tried the below and it is opening a new guest profile as expected can you check the same

"--profile-directory=Guest"

cheers

Thanks @Anil_G for helping me out.

I tried the same as you tried but failed to open Guest profile. Just noticed that if I don’t run WebDriver I can choose different profiles. Any suggestions?

Regards

@MiXs

even with this mode it is working

cheers

No,

changing profile only works when webdriver is disabled

@MiXs

My bad…you are correct when selecting Webdriver its picking the same user always irrespective of what value you provide

cheers

No problem, im just glad for all the help i can get :slight_smile:

Regards

1 Like