Using GetOutlookMailMessages and not getting the most actual email

Hi all,

I have a problem using the GetOutlookMailMessages activity. When using this for a shared inbox folder I do not get the most actual email from this folder.
It seems like there is an update missing in the background but I have no idea where or what to do to update the connection or whatever it is.

Has anyone any idea on this?

Thanks in advance!

Could be that “OnlyUnreadMessages” is affecting. Can you try to uncheck it?

@Maxinator

Ensure that the account or credentials you are using to access the shared inbox folder have appropriate permissions to access and read emails.
In Outlook, ensure that the shared inbox folder is set to automatically sync or update emails.
Sometimes, simply restarting Outlook and UiPath can help refresh the connection and ensure that new emails are fetched.
Ensure that you are using the latest version of the UiPath.Mail.Activities package. Outdated packages may have issues related to email retrieval.

The checkbox is unchecked.

Maybe to give some more background.

When I look into my outlook, I can see that there are new mails in the folder but currently the robot shows me the 5th email in the folder (yesterday it was the second, since some more mails came in).

I can see the mails on my installed outlook and also online in outlook365.

Double-check that your GetOutlookMailMessages activity is not configured with filters that might exclude recent emails. Verify that the “Filter” property is set appropriately.
Review the sorting order of emails. The activity may be fetching the emails based on the default sort order, which might not be the most recent. Consider sorting the emails by date, with the newest on top.

As you can see, there is nothing special in the activity. When changing the sorting to “oldest first” I get the (probably) oldest message and when switching back I still get that 5th e-mail.

The activity is inside the following activity if that’s relevant:

You don’t need the scope for GetOutlookMailMessages activity. If you want to use the Outlook 365 scope, you’d need to use different activites.

Thanks for the hints. It seems like the problem was an outlook setting. I had activated the option to “use the exchange cache mode”, which lead to problems on updating my inbox.

After unchecking that, it works as expected!

@Maxinator

1)Make sure that you have the appropriate permissions to access the shared inbox. If your permissions are limited, it might affect your ability to see the most recent emails.
2)Outlook may have a sync frequency for shared folders. It might not immediately show the most recent emails. Try manually syncing the shared inbox in Outlook to see if the new emails appear.
3)Close and reopen Outlook to refresh the shared inbox. Sometimes, simply reopening the application can help you see the most recent emails.