[Urgent] System error at initialization: Object reference not set to an instance of an object

Hi,

I’m having a problem with initializing my application.image

Can someone point out where my null value is at? I’ve already created an asset in my Orchestrator:

I’ve already imported my arguments to my invoked workflow:

I’ve also checked the Init Apps:

Here is my config excel:

I’m following this video tutorial as I was instructed to and followed the process to the T (or at least I think so) but he isn’t having the error I’m facing so I’m quite unsure where my null value is referring to

Hi @strqsr,
Can you please double click on this console error and show screen of the information window?

Hi @Pablito!

While I was trying to debug, I came across more errors:
image


This is from my Orchestrator:

This is from the console error:

P.S. My InitAllSettings:

Something is wrong here:

Hi @Pablito!
I thought that to be the issue too, but according to the video that I linked specifically this timestamp: https://youtu.be/7yPGkDFZFG4?t=3200

That isn’t the issue, I’ve even changed it to In/Out, however, it still has the same error that occurs:

From this timestamp you can see that he does have an error, but that was merely due to him not declaring his Name and Value in the Confiq Excel file which I have already corrected as well:

Definitely something is wrong with this tutorial. It makes no sense to use IN argument and call it OUT_xyz. Anyway I see that this whole project is based on REFramework so you need to go over whole process and check if every import argument for Invoke Workflow File activity has correct values etc. Please also remind about known issue I’ve described here:

1 Like

Hi @Pablito!

Thank you for your time, really!

Yes, I am aware of the current invoke workflow issues and have edited it accordingly, the strange thing is that his workflow works fine, despite it all. So I thought probably, there was something I missed in the tutorial.

The main problem is in my init App, I ran it in debug mode and it states this error:

And if you refer to the top, I’ve declared my values for the URL in my Config.xlsx and Orchestrator. Which leads me to believe that my Config settings didn’t run, but as it’s a template, apart from the Config, nothing else should be changed right?

This is my settings by the way.
image

I forgot to ask. Do you have robot connected to Orchestrator instance? Without it your robot will be not able to take such data from orchestrator. This might be a problem here.

Hi,

If this is what you mean then, yes!

Hi @strqsr

For debugging, if you want to take your value locally from config and not from Orchestrator assets, then you need to add a line in the Settings:
YahooURL in the Name and your URL in the Value

However, could you create a new workflow with just one activity Get Assets and test if you can fetch it? It seems to be issue here, so debugging it might solve your issue.

2 Likes

@Pablito @loginerror

Hey guys!

Thank you so much for your time today! I’ve finally solved the issue- had to re-do the entire project to ensure all of my arguments in my invoke workflows were filled, and the project ran smoothly.

Thank you for all the advises as I’ve learned new ways to debug my project.
Cheers!

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.