Unexpected error has occurred during the library compilation process: The given key was not present in the dictionary

I recently upgraded my UiPath version and now I am having trouble getting the “invoke workflow” activity to work.
When invoking my workflow I get the following error:

I have attached my blank process Parent workflow and also the Get last download workflow that I am invoking.

I do not understand what dictionary UiPath is referring to. I am fairly inexperienced with UiPath so any help on this would be greatly appreciated.
Main.xaml (9.3 KB)

Main.xaml (7.5 KB)

Hi @luke.neumeister

Welcome to Community!!

Reinstall studio and try again, this happens before for some users also, so there was some issue with the license of the UiPath studio

You can uninstall studio, restart the system, and install the studio

Try to connect to orchestrator once done.

I hope it helps!!

Hi @luke.neumeister ,

Maybe the upgrade involved also the conversion of Windows-Legacy to Windows project ?

Also, do you have Xaml files referenced out of the Project ? If so, it might be the reason, and in Windows type of Project, you would have to refer the xaml files within the project.

Try placing the Xaml files within your project and indicate that location as the workflow path and then check if it works.

Also another reference :

1 Like

Thanks for the reply. Yes the upgrade involved the conversion of Windows-Legacy to Windows project. Yes I was referencing the Xaml file outside of the project.

I tried making a copy of the Xaml file that I am invoking and placing it in the parent workflows directory. I then tried to use the relative path as shown below. But I am still getting an error.


@luke.neumeister ,

Could you make sure if it is invoked in Multiple areas, even there the Path is updated ?

Also, Try removing the Invoke workflow and check whether the error still occurs.

1 Like

Thanks for the reply. I tried this but unfortunately it is still not working

I tried again today without changing anything. It appears Changing it to relative reference made it work after all. I must have had to restart my UI Path. Thanks for your help.

One additional question. It seems like having a bunch of separate xaml files for each parent workflow that I develop will cause a lot of version control issues. Are there any alternatives to invoke workflow that I should consider that wouldn’t have version control problems?
I liked how invoke workflow worked in the past much better.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.