Unable to select elements in SAP 770 client

I am trying to execute my SAP automation script written and tested on SAP 720 client on the SAP 770 client. While executing, I have noted that although the element selector is same, when I highlight the element, the location is somewhere else. Also, the UI explorer is unable to select elements in this screen.

I have checked the same element path with the script recording. The path matches the previous element. But, cannot locate on the exact location with UiPath.

I need to click the ‘More’ button. The highlighted is the location it picks with the previous selector.

This the SAP client version I am using.

image

Is there any way to fix this? I tried by changing the client theme as well.

1 Like

I assume the selector needs to be tweaked. Can you try once killing all the SAP instance and then opening a new one and test this?

If the highlighted area is incorrect then click on indicate element and get a new set of element for selector.

We faced this for couple of selector when the SAP version got updated, we tweaked the selector to handle that version and all upcoming ones too

Actually, it doesn’t allow to pinpoint the exact selector with UiExplorer. It selects the whole area.

@urweeraratne

I guess script is not enabled. Can you enable the script on both client and server side and then check it once.

@urweeraratne

Hello Udani,
please look at this post from @LevKushnir. Lev describes in his answer the solution to a similar problem, or perhaps the same one.
Best regards
Stefan

1 Like

Woah, it worked… When I changed the display settings to 100%. Mine was at 125%… Thank you so much :slight_smile:

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.