Unable to find Image variable type


I’m new to UiPath, using Community version 2019.2, and I’m trying to save a screenshot as the final step in my robot to send with an email.

When I use the Take screenshot activity, I tried to output to a variable called screenshot. As you can see in the screenshot, I got an error

Compile error(s) encountered processing expression “screenshot”.
‘screenshot’ is not declared. It may be inaccessible due to its protection level.

When I tried to manually declare the variable, again, the Image type is not available unlike what I have seen in the tutorial.

Is this being replaced with another variable type? Or just not available in the community edition? Please help.

And this is the screenshot of what variables I can select from UiPath Studio.

@melhwchan Choose Browse for types it will open than search as which type you need


Create a variable(Ctrl+K) in the output of “Take Screenshot”, directly you will get the variable type as UiPath.core.image.



From the screenshot you uploaded, i find that you didn’t create the variable, just you wrote the word screenshot. If you want to Create the variable there are two ways.

  1. In properties of save image activity - Output - Screenshot - Press Ctrl+K, It will prompt for the Variable input there place your variable name.
  2. Directly got to variables which you can see below of the workflow window, there you will find create variable, click that, name your variable and select the type where directly image will not display, you need to select the browse types and select the image from the list by typing UiPath.Core.image.

Hope this helps