Unable to detect AA UiFramework activites


I have a process which was working fine until the other day where it now fails to detect activities that used AA framework. It is deployed in a Prod VM.

I have checked using ui explorer and have validated that it only detects the whole pane instead of individual elements. I used chrome as the browser but also checked with edge and it also fails to detect using AA elements but is working ok with default.

I have also tried opening the same website or any website with my dev vm and is working fine.

I tried reinstalling the extension but still have the same error.

Chrome AA

Chrome Default

Edge AA

Edge Default

1 Like


  1. Default: This option is the default selector used by UiPath Studio. It combines multiple methods, such as UI Automation, Accessibility, and others, to identify UI elements. It is recommended to use “Default” selector if other options do not work, as it provides a fallback mechanism.
  2. AA (Accessibility Automation): This option uses the Accessibility framework to identify UI elements based on their accessibility properties. This is particularly useful when automating applications that are designed to be accessible for users with disabilities, and may not have proper UI Automation support.
  3. UIA (UI Automation): This option uses the UI Automation framework, which is a Microsoft technology, to identify UI elements based on their properties, patterns, and relationships. It provides more precise and reliable identification of UI elements in Windows-based applications.

Best practices for UI framework selection in UiPath:

  1. Use “Default” selector as the first option, and only consider other options if it does not work.
  2. Use “AA” selector when automating applications that are designed to be accessible, and do not have proper UI Automation support.
  3. Use “UIA” selector for Windows-based applications, as it provides more precise and reliable identification of UI elements.

The combined impact of input method choice depends on the application being automated, type of action performed. In general, the “Default” input method is recommended, as it automatically selects the best input method based on the target application. However, in some cases, using other input methods like “Simulate Type/Click” or “SendWindowMessages” may be necessary for improved accuracy and reliability.

I have also encountered this problem. Have you solved it?

This happened to me on Sunday. Anything previously set up with AA no longer works. I’ve gone through and rebuilt most things, but I’m still stuck on one critical get-text activity that just won’t work anymore, which is very irritating. As far as I can tell, they wrapped some stuff into the “auto” selector and AA is now computer vision only? I’ve only been using UiPath for a couple months now, but if this is how it works, it’s pretty clear that it’s not going to be a good solution for us moving forward if production workflows just randomly blow up due to developers pushing surprise updates out…

Same is happening with me. In Production Solutions are not working, encountered Exceptions where I used AA for Selector.