Uipath.terminal.terminalconnection not defined while publishing a project

Hi, I have done an mainframe automation using terminal activities in uipath. the bot is working fine. but while publishing the process i am getting validation error as uipath.terminal.terminalconnection is not defined cannot publish the project. Please help.

Thanks in advance

Hi @Automation_Shyam

Check the packages installed correctly

I think some other workflow has error in that folder. Move your workflow to new folder and publish it.

Ashwin S

hi Ashwin . i tried after moving it to aother folder still i am getting the same error.

Please refer image.

@AshwinS2 The file path indicated the workflow xaml file only. All packages are installed are updated. and the bot runs well

Hi Automation_Shyam,

Did you fix this?
I have the exact same error!

I just updated from UiPath Studio v18.1.2.0 to v19.8.0.0, opened a year old project, and updated the dependencies. When double clicking the errors, it directs me to the errored activities, in two different workflows.

The weird thing is, I have a Terminal Session activity in another workflow (in the same project), that doesn’t give an error… with exacly the same setup, input, and output variables.

I have no idea what to do here… The UiPath.Terminal.Activities package is updated from v1.1.6464.20815 to version v1.3.3.

@casni . No Casper. I am still looking for a solution. I developed the workflow without terminal connection and that is working fine .

Apparently UiPath Studio v19.8.0 is a Community Edition, even though my Studio says otherwise.


When I uninstalled Studio v19.8.0 Community Edition and installed Studio v19.4.4 Enterprise Edition instead, everything worked as it should – also after updating all dependency packages to the newest versions.

Hope this can help someone, with a similar problem.

In imports tab, import “UiPath.Terminal”

@Automation_Shyam Any update?